Why is email 'from' dropdown not working

I upgraded to 7.9 yesterday.

I simply can’t figure out why the ‘from’ dropdown in Compose Email is not working.

I can send a test email from the setup area, but when I try to send an email to myself to test I get an error.

I don’t care about inbound email… I don’t even want it checked… but I want to send outbound email.

What am I doing wrong?

Sorry, 7.9 is having too many problems with Email, it’s best to just wait for 7.9.1 which should be coming out any day now.

I was having a problem with the From drop down as well. There was nothing in the drop down list. I just upgraded to 7.9.1 in hopes that it might fix the issue but same result. From drop down is empty. Any suggestions?

Where is the ‘from’ box supposed to get its data from?

dev77, that’s a good question. Mine is empty too.

I would say the content probably needs to come from what you set in Admin/Outbound email, or in the user’s profile email settings.

But I have those things filled in and nothing comes up in the “From box”. I did not set up Inbound Email, though; that might be causing my problems.

I did not set up inbound email either. I don’t want Suite checking email… just the ability to send it. So maybe that is the problem.

We’ll have to wait for someone to let us know. Before 7.9 we could just send email without setting up inbound.

The ‘send test’ works fine. But the ‘from’ box is empty and of course that throws the error.

I did not yet do yesterday’s 7.9.1 update. I’m told it does not fix the problem.

I was able to get it to work but the answer doesn’t make sense to me. You have to log in as the user and then go to the profile email settings. Then click on the Settings button. Go to mail accounts and define a mail account for incoming email. If you don’t use it to get their email then just leave the Check For New Mail option on the General tab to “Manually”. Then save the settings. Then the From drop down will get populated. What sucks is you have to do this for each user. Why the incoming email account settings affects this is what I don’t understand. I guess someone assumed that if you want to send outgoing email then you want to also check for new incoming email. Seems like a bug to me.


yes it is a bug, I reported it two days ago here:


it is confirmed, and yes, it happens when the inbound accounts aren’t configured. Of course the outbound accounts should work, but it seems some bug has crept in to that code.

This seems like a major bug and I hope they fix it quickly.

Will someone please re-visit this thread and let us know when a new update is released that fixes it? I subscribe to this so I’ll get an email notice.

Thank you.

Hi everybody,
i have the same problem. I use the version 7.9.3 with PHP 7.0. and all Admin-Data (Inbound and Outbound) are set but the dropdown is emtpy. Have anybody found an answer or get an information when it will be fixed?

Best regards and thanks

Hi all,

I got result Email ‘from’ drop down is working now. Kindly try the below step.

Create new group email account in Inbound email
Go to user profile page.Here we have the option for ‘email setting’.
Please confirm your email is correct.
Then click on the ‘setting’ button.
Popup box is came after click the setting button.
Click ‘mail accounts’ on the popup box and active incoming emails and save.




I have tried it but nothing changed. I use version 7.9.7

Is there a way to add manually the outgoing mail into source code?
I don’t need to select accounts. All users will use one mail account to send mails.

I have just upgraded to 7.9.8 and it works fine

@konstantinos0 don’t use email settings in the user’s profile then. Just have one account in Admin / Outbound Email Settings, and tick the checkbox so that everyone can use it.

But maybe you tried that already…


I tried all the solutions presented in the forums and nothing solved my problem.

I no longer knew what to do, so I remembered an add-on “STICKY NOTES” that I had installed a few months ago.

I removed this add-on and everything went back to normal. Problem solved.

Maybe it’s a tip for somebody.

My version is SuiteCRM 7.10.4

1 Like


I am on 7.10.5 now and appear to still be getting these same issues with the From field. Can somebody please confirm if it is still an unfixed bug in 7.10.5 or whether it’s just me having issues?

Thanks a lot.


7.10.6 is out now. It is a quick release we did just to get 3 important bugs fixed. It does include a bunch of other bug fixes, some of them email-related.

However, it is still not the sprint we had planned to go deep into the email issues and try to make a clear improvement in that area. That should be the next one.

Thanks for your patience. We’re very eager to work on email fixes, but “life” has been throwing some delays in our direction, unfortunately…

@pgr thanks for the heads up re 7.10.6 which is a big step in the right direction.

I just installed this, did a quick repair and rebuild and did a clear / rebuild all the various JavaScript bits under the repair section for good measure. I have just one strange problem remaining now.

I set the system email settings under Admin / Email Settings. and click test send and everything works great. The person receiving the email sees it as being from whatever I stipulate in the “From” name field. This is good and what you would expect.

When I then save the settings and click an email in contact or accounts, it all looks good and sends the email, however the recipient sees the From field as saying “Root user” instead of whatever I stipulated in the “From” name field, although the from email is the correct email as set in the “From email” field.

Any ideas what might cause this and what I might need to change in order for it to pick up the “From” name setting, just as it does when I test it?

Below is what shows in the suitecrm.log file but I’m not quite sure which bit if any is relevant:

Thu Jun 7 16:40:52 2018 [3353398][----][FATAL] log call at: modules/Administration/index.tpl:54 - MY_FRAME is not set
Thu Jun 7 16:41:49 2018 [3355158][----][FATAL] log call at: modules/EmailMan/tpls/config.tpl:444 - styleChecked is not set
Thu Jun 7 16:43:55 2018 [3358067][----][FATAL] Exception handling in ////include/MVC/Controller/SugarController.php:402
Thu Jun 7 16:43:55 2018 [3358067][********-
---][FATAL] Exception in Controller: Error retrieving record. This record may be deleted or you may not be authorized to view it.
Thu Jun 7 16:43:55 2018 [3358067][
---][FATAL] backtrace:
#0 /
/include/MVC/View/views/view.detail.php(101): sugar_die(‘Error retrievin…’)
#1 ////include/MVC/View/SugarView.php(207): ViewDetail->display()
#2 /
///include/MVC/Controller/SugarController.php(432): SugarView->process()
#3 ////include/MVC/Controller/SugarController.php(375): SugarController->processView()
#4 /
///include/MVC/SugarApplication.php(109): SugarController->execute()
#5 ///****/index.php(52): SugarApplication->execute()
#6 {main}

Thanks a lot for any help


Keep an eye on Github activity, the “From name” mess is about to be cleaned up in the next few days, I’m hoping.

Can you tell me who is working on this and where their repository is? I’ve got some code that allows users to send as themselves though the system outgoing server, and I was going to create a pull request for it. A bit of it is documented in Issue 5774. https://github.com/salesagility/SuiteCRM/issues/5774