white screen after compatibility check

I would like to host suiteCRM on an external one.com server.
I uploaded the files to a subdomain and connected via SSH to set the permissions. Everything went fine so far.
I opened the install.php file to install suiteCRM, but after the compatibility check I run into a white screen.

The installation log file says the following:
2018-02-20 10:11:36…installerHook: Could not find custom/install/install_hooks.php
2018-02-20 10:11:41…Begin System Check Process *************
2018-02-20 10:11:41…XML Parsing Support Found
2018-02-20 10:11:41…MBString Support Found
2018-02-20 10:11:41…ZIP Support Found
2018-02-20 10:11:41…/custom directory and subdirectory check passed
2018-02-20 10:11:41…cache directory and subdirectory check passed
2018-02-20 10:11:41…/module directory and subdirectory check passed
2018-02-20 10:11:41…/upload directory check passed
2018-02-20 10:11:41…/zip check passed
2018-02-20 10:11:41…PCRE version check passed
2018-02-20 10:11:41…installerHook: Could not find custom/install/install_hooks.php
2018-02-20 10:11:41…php.ini location found. /etc/php/php-7.0.ini
2018-02-20 10:11:41…Outputting HTML for System check
2018-02-20 10:11:41…No Errors were found *************
2018-02-20 10:11:41…installerHook: Could not find custom/install/install_hooks.php
2018-02-20 10:11:48…installerHook: Could not find custom/install/install_hooks.php
2018-02-20 10:11:52…Begin System Check Process *************
2018-02-20 10:11:52…XML Parsing Support Found
2018-02-20 10:11:52…MBString Support Found
2018-02-20 10:11:52…ZIP Support Found
2018-02-20 10:11:52…/custom directory and subdirectory check passed
2018-02-20 10:11:52…cache directory and subdirectory check passed
2018-02-20 10:11:52…/module directory and subdirectory check passed
2018-02-20 10:11:52…/upload directory check passed
2018-02-20 10:11:52…/zip check passed
2018-02-20 10:11:52…PCRE version check passed
2018-02-20 10:11:52…installerHook: Could not find custom/install/install_hooks.php
2018-02-20 10:11:52…php.ini location found. /etc/php/php-7.0.ini
2018-02-20 10:11:52…Outputting HTML for System check
2018-02-20 10:11:52…No Errors were found *************
2018-02-20 10:11:52…installerHook: Could not find custom/install/install_hooks.php

A little help here would be very nice. :cheer:


please check if you have all the necessary PHP modules installed. Start with checking zip/unzip modules.

You can also clear previous installation attempts by deleting “upload/upgrades”

Make sure that not only permissions but also ownerships are correct: you need to do that recommended “chown” to match your web server user name.

You mean that I have to check whether the upload worked properly? And all modules were uploaded completely?

I simply deleted the upload folder in the suiteCRM directory and tried again. The compatibility check says i need to have the a writeable upload directory. The good news is, that it did not only show me a white screen.

To set the right permissions and ownerships, i used the three commands in the installation guide.
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

BUT, sudo did not work via SSH connection AND there is no file named config_override.php
So I skipped the sudo command for all 3 lines and modified the “www-data:ww-data” to match my web server user name.

the command ls -l now shows the following:

-rwxr-xr-x 1 2376 Feb 19 16:04 maintenance.php
drwxr-xr-x 1 8192 Feb 19 16:25 metadata
drwxrwxr-x 1 3304 Feb 19 16:33 modules
-rwxr-xr-x 1 2890 Feb 19 16:04 pdf.php
-rwxr-xr-x 1 304 Feb 19 16:04 php_version.php
-rwxr-xr-x 1 73 Feb 19 16:04 robots.txt
-rwxr-xr-x 1 3588 Feb 19 16:04 run_job.php
drwxr-xr-x 1 276 Feb 19 16:41 service
drwxr-xr-x 1 448 Feb 19 16:41 soap
-rwxr-xr-x 1 4091 Feb 19 16:04 soap.php
-rwxr-xr-x 1 154 Feb 19 16:04 sugar_version.json
-rwxr-xr-x 1 2296 Feb 19 16:04 sugar_version.php
-rwxr-xr-x 1 0 Feb 19 21:29 sugarcrm.log
-rwxr-xr-x 1 170 Feb 19 16:04 suitecrm_version.php
drwxrwxr-x 1 152 Feb 19 16:41 themes
drwxrwxr-x 1 84 Feb 20 11:28 upload
-rwxr-xr-x 1 2980 Feb 19 16:04 vCard.php
-rwxr-xr-x 1 2248 Feb 19 16:04 vcal_server.php

Do “ls -al” to see also the ownership. Are you sure about your web server user name?

Don’t worry about config_override.php, it gets created automatically at the end of the installation.

My comment about the PHP modules means that in php.ini you must have enabled certain modules. The unzip module needs to be used by the installer.

In Ubuntu 16.04, with PHP 7.0 these are all the modules I load:

apt install zip unzip php-mbstring php7.0-mbstring php-gettext php-xml-parser php7.0-zip php7.0-imap php7.0-gd php7.0-curl phpmyadmin

If you can’t install modules this way, because you are on shared hosting, then look in CPanel under PHP settings, normally there are a few checkboxes you can tick to activate these modules (or ones with similar names).

Keep checking install.log for errors.

Okay. Thank you very much for your help so far!

I am relatively sure about the web server user name because I have to use the same name to log in via SSH.

The main issue seems to be the PHP modules because one.com won’t tell me which modules they offer and give me no option to activate them manually. They support PHP error messages.

So I think installing suiteCRM on an one.com shared hosting server is completely impossible, isn’t it?

Do they let you have a php.ini file in your directory?

Shared hostings can’t let you edit the real php.ini, but they often have a way of picking up these files from your directory, filtering them so you only get to change a few select options, and then apply it.

Sometimes you can activate modules from there.

It’s true that SuiteCRM has requirements and if your hosting doesn’t allow them, SuiteCRM can’t run. But I’d say the requirements are quite common and simple, and normally even restrictive shared hostings allow for them.

Unfortunately the won’t let have me a custom php.ini file.
The support team told me that suiteCRM won’t work because the do not support the exec() php module.

Maybe I should have asked the one.com support before bothering you. I am really sorry!

BUT this could be useful for someone else. The one.com support officially stated that suiteCRM won’t work on their servers.

I’m not sure that exec() thing is a requirement. I know of one place in the code where we use it (I wrote it myself) but it has the necessary fallback methods in case the hosting doesn’t allow it, I covered that case.