White/Blank Screen After Clicking Next to Commit Upgrade


On a test machine where I’m running a clone of my production system, I tried to do the upgrade from v7.11 to 7.1.2. All was going well until I got to the last step to Commit the upgrade. When I hit the next button I got a blank screen immediately. Now, the site will not load. Did I do anything wrong or is there something I need to check for. Also, is there a way to undo the upgrade and reattempt it?

I’m glad I followed your warnings and didn’t do this on the production server.

Did you set permissions correctly before the upgrade?

Check the logs to see if anything strange has happened.

The check didn’t reveal any issues with permissions so I didn’t think to check anything. I did check the log file located inside the install folder and saw this:

Tue Jul 29 11:13:02 2014 [21434][-none-][FATAL] Configuration variable date.timezone is not set, guessed timezone America/New_York. Please set date.timezone="America/New_York" in php.ini!

So I checked the php.ini file and I did have an uncommented entry with a default timezone as follows:

date.timezone ="America/New_York"

I restarted apache a couple of times but still getting a blank/white page. Url to my test install is http://test.centraltruckcenter.com/suitecrm/

Is there anything in the file sugarcrm.log or in the apache/php logs?

Unfortunately no. The errors above are all I found in the sugarcrm.log file. So I decided to turn on error display and the following shows now on the blank page:

Warning: file_get_contents(cache/themes/Suite7/pathCache.php): failed to open stream: Permission denied in /var/www/html/suitecrm/include/SugarTheme/SugarTheme.php on line 296

Fatal error: sugar_file_put_contents_atomic() : fatal rename failure '/tmp/temps1Qo9L' -> 'cache/modules/UserPreferences/UserPreferencevardefs.php' in /var/www/html/suitecrm/include/utils/sugar_file_utils.php on line 187

Looks like a permissions issue. I checked and the permissions on the specified folder is 0777 recursively with apache (www-data) as both the owner and group. Am I missing something here?

I managed to resolve the issue by running the following in order to adjust the file permissions after the upgrade:


sudo chown -Rv www-data:www-data /var/www/html/suitecrm


sudo chmod -Rv 770 /var/www/html/suitecrm


This cleared the problem, but led me to believe that the upgrade script is adding new files or attempting to replace new files with wrong permissions - could this be possible? To test this I attempted to run the upgrade wizard again. It automatically sent me to the last step and informed me that the upgrade was done, so I pressed the done button. Viola the white/blank screen again. So I ran the commands above in sequence and I’m able to access the site again.

Is it possible that I may have uncovered a bug? I’m reluctanct at this point to do the upgrade on the production site. Please advise, thanks.

edit the config.php file and set both the right permissions as well as owner (user) and group.
‘default_permissions’ =>
array (
‘dir_mode’ => 1517,
‘file_mode’ => 420,
‘user’ => ‘<your-user/owner>’,
‘group’ => ‘’

Thanks. This, this is what I have now:

  'default_permissions' => 
  array (
    'dir_mode' => 1528,
    'file_mode' => 432,
    'user' => 'www-data',
    'group' => 'www-data',

Should I change the dir_mode and file_mode numbers also to match what you posted?