Web Person Form is not being accepted by entry point at SuiteCRM v8.1.3

Objective: To insert Web Form Data into SuiteCRM

I just installed a new SuiteCRM instance v8.1.3 via Softaculous.
Then, I created a new WEB PERSON FORM but this questionnaire is not being submitted.

The browser error is:
“This page isn’t working
suitecrm.my-domain.com is currently unable to handle this request.

The Chrome console does not show any error, and suitecrm.log for Log Level: ERROR does not show any error.

The web form created is:

<form action='https://suitecrm.my-domain.com/public/index.php?entryPoint=WebToPersonCapture' name='WebToLeadForm' method='POST' id='WebToLeadForm'>
    <div class="row"><div class="col"><label>Last Name: <span class='required'>*</span></label><input id="last_name" name="last_name" type="text" required></div><div class="col"> </div>    <div class="clear"> </div>
<div class="row center buttons">
    <input type="submit" onclick="submit_form();" class="button" name="Submit" value="ENVIAR" />
    <div class="clear"> </div>
<input type='hidden' id='campaign_id' name='campaign_id' value='30f60fc0-a812-f264-dfc5-63389'>
<input type='hidden' id='redirect_url' name='redirect_url' value='https://suitecrm.my-domain.com/subscribed/'>
<input type='hidden' id='assigned_user_id' name='assigned_user_id' value='1'>

<input type='hidden' id='moduleDir' name='moduleDir' value='Leads'></form>

I also verified in config.php to see if URL was correct as https://suitecrm.my-domain.com/public

I also set up the permissions as:
sudo chown -R user:user .
find . -type d -not -perm 2755 -exec chmod 2755 {} ;
find . -type f -not -perm 0644 -exec chmod 0644 {} ;
chmod -R 775 cache custom modules themes data upload
sudo chmod 775 config_override.php 2>/dev/null
chmod +x bin/console**

I am running out of ideas. Any suggestions?

Have you tried making the URL point to public/legacy/ instead of just public/ ?

HI @pgr

As per your suggestion, I tried with:

my-domain. com/public/legacy/index.php?entryPoint=WebToPersonCapture
instead of
my-domain. com/public/index.php?entryPoint=WebToPersonCapture

and the Chrome response error was:

This page isn’t working

my-domain. com is currently unable to handle this request.
HTTP ERROR 500 ###

You could check both your logs for any FATALs

Hi @pgr

In order to troubleshoot and chech the PHP versions, I switched from PHP 8.0 to PHP 7.4 and the Web Form was sent successfully to SuiteCRM.

So I am going to compare which PHP extensions are in PHP 7.4 but missing in PHP 8.0.
Thanks for your suggestions.

If you can find a FATAL error in php_errors.log with PHP 8.0 that makes a good issue to open on github. Especially useful if you get a full stack trace to go along with it

Im having the same issue. Any resolution?