Want to customize contacts

Problem: I want to add descriptive features to all contacts. e.g., drop downs, “is a golf player/is a tennis player/no sports”, “handicap less than 10/plays 3 times per week/etc.”

Situation: I couldn’t find any functionality for the customization of contacts.

You can easily add fields from Admin -> Developer Section -> Studio

Once you are in Studio you select the Contacts module and add the new fields that you need.

You have to remember to add the new fields to your layouts and search forms as per your needs.

Once done you have to apply the changes with Save & Deploy button (for each change).

If you also need to create new lists to be used in your dropdowns, this has to be done before adding the relative field in Studio, by going to Admin -> Developer Section -> Dropdown Editor.

Once you have done all you need it is probably a good Idea to run a Quick Repair and Rebuild.

Hope this is what you required,


Thank you. I tried adding a drop down. The system won’t accept that. I try"Save", error message “undefined”.

Yesterday I tried adding a user. I also got such error message “undefined”?

Is the system not installed correctly?

“undefined” labels instead of the proper text are are often a symptom of a permissions error.

You should check that permissions are set correctly throughout your whole SuiteCRM installation, in the config.php file and (twice) in include/utils.php

You should then run Quick Repair and rebuild a couple of times and, if at the bottom of the Quick Repair and rebuild screen there are some things to fix you should proceed as instructed.

Additionally you should check your logs to see if there are any php or SuiteCRM errors.

Thank you, amariussi.

I succeeded in creating additional fields. Apparently, my error in naming those fields was the causeof the error. Perhaps a blank in between 2 words.

It is somewhat logical what you advised that in addition to the creation of a field, the layouts and search forms need to be done too. I tried doing so but failed. I found the “Layouts” panel in Studio Contacts, but none of the sub-panels wouldn’t do what is needed. The “Layouts / EditView” sub panel has a strange function feature: I succeed in marking a field which I created, a very generic one, namely “Company”, and to pull it across the panel by holding down the mouse left klick switch. I dropped “Company” into the “Layout/Overview” area. It replaces another, namely “Department”. Instead of being added in. Then I refresh one contact of the data base to see if “Company” is shown. Negative. Then I marked another field tag, namely my newly created one “Profession”. Unfortunately, that field tag is on the left side very low in the list, and the display of the Layout Overview area is very high on the right side, so it is impossible to drop the marked field item “Profession” where it is supposed to go at all.

I am surprised. This one and the other settings and modifications of mine are very common. The administrator’s works are far from intuitive. Additionally, I couldn’t find any documentation/manual.

Could you please once again advise, please in greater detail. Thank you.

In order to add a field in the layout from Studio first you need to add a new row:

from the left side Toolbox you drag the “New Row” item to the right side to the position you want. (sometimes it is difficult to drag to the last position in a panel so put it first to the one before last, and once it is in the panel move the las above so that yours becomes the last).

You will notice that the newly added row is split into two slots called “filler” for two fields. You can add a field in one of these filler slots by dragging them from the left-side Toolbox.

If you only want one field add only one and leave the other blank or fiddle with the “+/-” sign on the side of the row. Then save and deploy.

Navigate to the layout of module and your field will be there.

Well, this sounds feasible.

Where “Add new row” is perhaps supposed to be, I have 3 different kinds of “undefined”. Ok, I guess this placeholder is equal to “Add new row” and drag it over from Toolbox to Detail view. Ok, it adds it in. Ok, I can drag my newly created field “Company” over the newly created “undefined” and replace the latter. Ok, I klick “save and deploy”. From here the problems begin:

The “Company” field and content is still not diplayed in "Contacts after a refresh of the page.
I cannot add another “undefined” row into the Detail view area.
I cannot drag the “Profession” field at all because, as said, it is too far down in the list on the left. It is impossible to do both at the same time, holding the mouse button AND scrolling the display in upward direction.

The video https://youtu.be/OOt2xSYm2f0 shows/confirms what you explained. But as I explained, these simple steps can in my reality not be executed.

1 Like

If you have “undefined” labels you most likely have a permissions problem.

In order to solve it you have to:

  1. Edit the permissions in you SuiteCRM_main_folder/config.php
  2. Edit the permissions in you SuiteCRM_main_folder/Include/utils.php (here there are two places where you have to do it)
  3. Reset your whole SuiteCRM folder/subfolder/files manually to correct permission

There are lots of posts on this in the forum, including a script to perform 3.

After yo have done you should, from within SuiteCRM, run Quick Repair and Deploy two or three consecutive times. When you do this you should also check if, at the bottom of the screen, you are instructed to perform actions to finish the Repair (possibly in the DB)

1 Like

Here is more in detail what I recommend you do (on a Linux/Unix machine):

  1. Edit the permissions in you SuiteCRM_main_folder/config.php
    With your favourite editor open config.php and serch for the following:
    array (
    ‘dir_mode’ => 493,
    ‘file_mode’ => 493,
    ‘user’ => ‘’,
    ‘group’ => ‘’,

Change 493 in the first line (dir_mode) with 1533 and leave 493 in the second line (file_mode)
Then enter between the two quotes your Unix user and inthe next line your Unix group (if you have cpanel, you should be able to see them from a file listing).

So the result should be:
array (
‘dir_mode’ => 1533,
‘file_mode’ => 493,
‘user’ => ‘YOUR_UNIX_USER’,
‘group’ => ‘YOUR_UNIX_GROUP’,

where YOUR_UNIX_USER and YOUR_UNIX_GROUP should be replaced by the actual values

  1. Edit the permissions in you SuiteCRM_main_folder/Include/utils.php (here there are two places where you have to do it)
    Follow the same instructions as above.
    However be careful because in this file, instead of user and group you will find chown and chgroup (replace also these to ‘user’ and ‘group’ as in config.php.
    Note that in this file there are two places where you have to do the changes.
    Also note that this modification is not upgrade safe so, if you upgrade the system you may have to redo the same things again.

  2. Reset your whole SuiteCRM folder/subfolder/files manually to correct permission
    You have to reset all yuor permissions to 755 and 775 according to the file and folder.
    For this purpose I am attaching a php script that I have created that does it. You just have to copy it to the top folder of the SuiteCRM installation and then run it from a browser by typing its full url (eg: http://www.yourdomain.com/yourSuiteCRMPath/chperms.php
    Note that it is set not to display anything and it may take a few seconds to execute.

Once done you can go log into SuiteCRM and run Quick repair and rebuild a couple of times. then run again the script that I have attached (I recommend that you run it every time you do something in Studio (I have set up a cronjob that runs it every 15 minutes!)

1 Like

Thank you very much, amariussi. With yours and the kind help of an expert, I might have the problem resolved for now. No “undefined” error messages at the moment.

Still, the creation of extra fields challenge remains.

I did do successfully this-

  • created field “Company”
    Comment: This was relatively easy because "Company has a “C” as initial letter. Therefore it is listed high in the Toolbox list and can easily be dragged and dropped onto a filler.

  • created fields “LinkedIn Contact of mine” and "Profession.
    Comment: This was relatively complicated because the initial letters are L and P. Therefore listed low in the toolbox. Drag IMPOSSIBLE. So I ridiculously worked around this by temporarily naming the fields “ALinkedIn Contact of mine” and AProfession.

  • clicked Save and Deploy.

Still, in the “Contacts” view of one contact item, I do neither see the field labels nor the actual content.

What is still missing, please?

  1. Difficulty in dragging
    I just tried and you are right it is not possible to scroll up or down while dragging a field.
    My workaround is different than yours: I place the field in a position where I can see it and then I drag it up (if necessary in more steps). In this way I don’t have to rename it.
    Possibly this is a bug.

  2. Created fields are not visible
    Are you 100% sure you saved and deployed?
    Try running Quick Repeair and rebuild as well as the script I sent you (do it more than once) and it may solve the issue

1 Like

Many thanks again. The trick is to check the checkbox „Sync to DetailView“ inside the editor-wizard where the change has to be confirmed with „Save and Deploy“. I had previously unchecked this. Now all good.