Very slow when saving any record - what is the cause?

Does anyone know what causes this and what I can change.
I am still on v 7.1.2 :dry:

Hi there,

There could be many reasons for speed issues. Internet connectivity, server load, large/unoptimised database. If you are experiencing slow speeds, investigate these areas first to see if you can find a solution.



None of those would be a problem as all other sugar instances are running at full speed. SuiteCRM though when you save records are extremely slow. Sometimes it can take up to 20seconds to save something. Especially when creating new contacts/leads.

Hi thanks for the reply but it is not the internet or the server as I have other SugarCRM’s on the same system running at great speed. The problem is only when saving. Especially when importing vcards or creating a tasks, calendar event new invoice. It is the actual saving that is a problem not opening up windows etc. :ohmy:

HI ,

Are You triggering any mail on logic hook ?? if not than generally

Follow the Below link to optimize the speed :

I have the same problem. Interface runs OK at speed, but when creates / edit register they took a lot of time.

My environment are: Local connection between CRM Server - CRM Client - CRM Database (each one different machine)
Database: MSSQL with 28+Gb RAM / 16 Core, all connections run at 1gbps.

The SQL machine doesn’t have speed problems (I can run INSERT / UPDATE / SELECT queries without performance problems).


I am also experiencing the same issue. This started happening around 3 weeks ago for no apparent reason. My instance is hosted in AWS. Normal viewing operation of CRM modules is fine as is the case with other people. However, it takes around 20 seconds when saving or editing records in any module. My version of Suite is almost stock, other than a couple of custom fields. I’ve spent hours on going through MySQL database performance hints and tips as well as SugarCRM performance hints and tips. None of them make a noticeable difference. I even recreated my installation locally in a virtual machine to rule out any Internet lag or AWS hosting related issues, same problem. I’m logging slow queries both in Suite and in MySQL, there is nothing that indicates slow responses, either in the application or on the database. Anyone got any further with this issue or found a fix?



I upgraded to 7.1.3 today and it has fixed the slow saving/editing issue. Just thought I would post so others can benefit.


1 Like

I had a similar issue here:

The problem was directly related to Workflows with huge audit histories (most likely from using the “repeated runs” option)

Had a similar problem. Resolved it when i realized that there some orphan apache processes running. Stopped the service, killed all the processes forcefully and restarted. Voila!