Very slow bulk delete

We selected about 2,000 leads and did ‘bulk action - delete’
The records are being deleted at a rate of about 6/hour!
So it will take 2 weeks…
In the meantime - our CRM (and the whole server) is running very slow (although CPU usage < 10%)
I have even rebooted the server and It is still slowly deleting in the background.
Any ideas?

Suite 7.10.9 / Windows Server 2012 / Apache / mySql

Try turning off AOD. I seem to remember I had this problem once and I think it was trying to update the index as it was deleting the records and taking forever. It took a number of hours to complete a few thousand records, but nothing like you’re describing.

If it works out for you, when done turn AOD back on.

Thanks for the suggestion, but AOD is not enabled.

I have the same situation when I try to delete only 40 calls per page!
AOD is disabled.

Mass updates are always slow in suitecrm, many times it just broken up.

You can try turning on “log slow queries” in Admin / System settings and seeing if it’s delayed in the database.

If it is, then run the first query in this post, to check for overgrown tables:

Another technique that might help is to increase log level to DEBUG, then run this on a separate SSH window (make sure your terminal saves thousands of lines of scrollback):

tail -f suitecrm.log

Now run the long operation (preferably when nobody else is using the system) and when you see a noticeable delay, press “return” a bunch of times.

Later, you can grab the entire scrollback from the terminal and examine it in a text editor. Your blank lines will mark the spot where the delays occurred, and you can try to figure out what it was doing at the time…

When a call is deleted this SQL is executed:

SELECT id FROM calls
WHERE repeat_parent_id = ‘<call_id>’ AND deleted = 0
ORDER BY date_start

On my calls table it takes 18 seconds to execute!

I put an index on that column and now is executed in 0 seconds.


That seems related to recurring Calls created from the Calendar. I am not sure how these are stored in the database, but I wonder if you should also try to clean up your data (remove old entries)…

Hey guys
I’m seeing very slow bulk update action with a fairly new SuiteCRM version ( 7.10.22). Anyone have any more experience with this or any pointers?

Turning off AOD has no effect.

I’m doing a bulk update of a custom dropdown field in the Accounts module. Mass update of 700 entries takes around 7 minutes.
Our host has a nginx proxy thing setup that gives a gateway error after 1min. The process continues in the background, but the crm is unresponsive until the bulk update has finished in the background.

Is there anything we can do about this? It makes no sense to me that changing a field would be so inefficient.

Workflows are turned off.
no logic-hooks set up.

Any ideas?