Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Ventana de redactar email en actividades de paquete no se visualiza.

SUITE CRM Versión 7.9.17
Sugar Versión 6.5.25

Hola.

Mi problema se encuentra en la ventana emergente al redactar email en la sección de actividades en los paquetes, dicha ventana no se visualiza al dar click en redactar email, solo se queda cargando.

Cabe recalcar que esta problemática solo se presenta en el apartado de paquetes, se entro en cualquier cliente y me dirijo a la sección de actividades y redactar email, puedo hacerlo sin problemas y enviarlo.

En mi navegador me aparece este error.
[sugar_grp1_jquery.js?v=uxwWM79U0p4RKkSpq6r9sQ:7660 Uncaught TypeError: Cannot read property ‘elements’ of undefined
at n.fn.init.$.fn.openComposeViewModal (sugar_grp1_jquery.js?v=uxwWM79U0p4RKkSpq6r9sQ:7660)
at HTMLAnchorElement.onclick ]

Si alguien pudiera ayudarme diciendo cual podría ser mi problema o como podría resolverlo lo agradecería.

Tienes configurada alguna “signature” de email? He leído en otro sítio que eso genera este error.

Por favor haz algunas pruebas y dinos que tal.

Es muy posible que esto ya se haya arreglado en una de las versiones más recientes…

Hola y gracias por contestar.

Hice pruebas con firma de correo agregada en el usuario, pero aun así la ventana para redactar email continua sin aparecer.

En la sección de clientes en las actividades y redactar email continua funcionando bien e incluso a darle redactar email, la firma agregada al usuario se carga sin problemas.

Alguna otra recomendación o consideración que deba tener en cuenta.

Gracias

Lo que leí en otro sítio era lo opuesto: que cuando había firma, no funcionaba - solo sin firma era posible.

Si puedes hacer el upgrade para 7.10.x me parece que se solucionaria. Si, por lo menos, lo puedes intentar en un ambiente de testes (con un clone de tu produccion) y funcione, después se podría buscar cual el Issue en Github que soluciona esto…

Perdona el malo castellano que no es mi lengua…

Descuida, gracias.

Realice la prueba retirando la firma e intente redactar un correo en el apartado de leads y funciono bien, depures intente lo mismo en el aparatado de paquetes,
des afortunadamente continua sin cargar la ventana para redactar el correo.

Habrá alguna otra recomendación o modificación que tenga que considerar para que funcione.

Encontré el problema revisando el inspector del navegador:

Cuando Compose email on Account se abre la ventana y se carga correctamente, revisando el inspector en esa ventana se ve esta información en las opciones de actividades.

Cuando repito este proceso en la Opportunitie la ventana no se abre, al checar con el inspector en esa ventana en las opciones de actividades me encuentro con esto.

Como notas, lo que ocurre en la Opportunitie es que los datos no se cargan al entrar en Opportunities.
Por eso al dar clic en Compose email en uno se carga la ventana y en otro no.
¿Como puedo resolver esto?

Y habrá algun error en suitecrm.log?

Busca algo al exact momento en que está abriendo esa pantalla y ese link no queda bien construido.

Hola.

Realice las pruebas buscando algún error desde que cargaba el paquete y checando el segundo en que lo realice en el log, también al dar click en actividades y al dar clic en compose email, pero no pude encontrar ningún error, solo las consultas realizadas y warning y demás pero sin relación con compose email.

En mis testes en 7.11.4 funciona correctamente. Las oportunidades no tienen ningun campo con email, entonces la ventana de “componer email” no empieza con la dirección rellenada, pero la ventana abre normalmente.

Así no es fácil ayudar, porque aqui todo va bien… :huh:

1 Like