Values sometimes not saving for custom fields

I have 4 custom fields in our SuiteCRM 7.2.1 opportunities module, about 50% of the time when a value is edited on a record the value doesn’t save to the DB
It appears to be record based ie if a record doesn’t save it’s custom field values correctly it never will but if a record can save it’s custom field values then it always will!
It’s quite hard to track the cause of the problem because I can’t find any errors in the LOGS.

Has anyone had this issue before?



This issue gets weirder, I have added another custom field to the same module.
And the values stored in that field appear and disappear seemingly randomly, If I’m looking at the Module’s List view with the new field listed, the values won’t be visible and I can’t search for them either, If I then open the field in Studio and press Save, I can then see the field values and search on them for a short period of time, then without warning they disappear again.
The field values remain in the DB
It’s becoming quite an issue

On top of this
Occasionally User names will only display as their last name then a short period later they will display as the full name so on and so on.


I have determined that this issue seems to be related to records that were created via Import.
Also upon import my Auto Increment field is skipping a number in the sequence when records are imported, ie:5000 then 5002 then 5004 etc
Does anyone have any idea about what could be causing this?

Just as a note I have done a lot of Quick Repairs and file permissions resets.
Our server administrators say they can’t provide me with the user and group file owner for security reasons, so following a sugar post regarding this I set our permissions as they reccomended


I am facing the same issue, values appear/disappear randomly. Did you succeed in solving this.


Still no luck :frowning:

Hello everybody.

I was having the exact same problem, and found out that they’re related to bad written Logic Hooks I developed myself. Disabling them solved the problem.

Before that I’ve also tried something related to bad permissions in the MySQL database, please have a look at this article:

Hope this helps!

This is still a persistent issue for me
Luckily I only have to update 4 records a month directly on the database.

@Webber neither of your solutions worked for me unfortunately

Does anyone have any ideas on the best error log to look at?


Ok I finally figured out and solved this issue.
I was migrating servers so I thought I would have a crack at solving this issue once and for all.

It turns out the issue I was having was being caused by the Logic Hook for the jjwg_Maps module
From that module I disabled the Enable all Logic Hooks option


Glad you solved your case!

Let me just report that I have just had a very similar situation solved. In case somebody with my underlying issue, rather than yours, would find this thread on googling just like I did.

In my case I had put some custom fields in a rarely used subpanel, and one of the fields had been set as “required”. (I thought I had changed this back to not being required, so my thoughts didn’t go that direction.) On saving, no error message could be seen, only that it simply did not save. But in secret, the record was crying to have data put in that required field. Thinking back, obviously the odd occurences of saving which worked would happen in records which had data entered in that field. When you neither see it or suspect it, it comes across as random and obviously leaves no error log trace.

Thanks to fellow forum user urdhvatech who quickly zoomed in on the issue after first excluding that it had been caused by my rich wildlife of file permission settings, which I first suspected.

This is happening to me in the Cases Module, I have a custom hybrid of ExtendedPhone & FlexRelate, there is stuff in the databases FP_events & Opportunities I can attach them to the Case but they are not there after I’ve saved.

Weirdly I can edit the case and try again, then it will save. It’s intermittent in that some old cases still have the data against the,.

I suspect me deleting some maps fields in FP_events & Opportunities has damaged by custom field in some way??