V8.3.1 does not display Calendar (weekly) for admin

It displays monthly for admin, not weekly. Users are displayed. Perhaps this is an easy fix?

Calendar displays properly for normal user.

I just tried it on my installation, and it looks fine.
The difference is your admin view seems to have the date format in a different order.
Maybe that has something to do with it?

I changed the time format and time zone but still not working. The calendar works for a normal user I set up. The admin calendar works for month and shared month but does not work for DAY, WEEK or SHARED WEEK. I know there are code variations for those different selections. I’ll try to see why this is occurring with some extra logging. Thanks for helping.

Getting log data would be for the best,
Don’t know if you have already, by also test if it happens to another admin account,
This should see if it is account specific or admin specific.
If it is account specific it could be caused by a task within it.
if it is admin specific it could be caused by something permission related.
Also I would also check if there is anything in the custom folder that could cause this.

Thanks for those ideas.

  • another ADMIN was able to see weekly calendar so it is not related to that
  • My monthly calendar and tasks show.
  • There is nothing in the custom folder for calendar module.
  • The suitecrm logs have no fatals or errors and I am on debug settings with no Calendar debugging issues showing. I don’t think there is much logging in the calendar module.

I’ll figure it out one day.

So it is something related to your user account.
It could be something in an activity that it does not like.
Also you could check the console within the browser to see if there is any JS errors.

I had a similiar problem, with both weekly and daily calendar showing up as blank. The issue was in the calendar settings, where I had to define a range of hours for the workday which was set from 7:00 to 00:00 whereas the latter was supposed to be a number higher than 7

That was the problem. In Calendar, Settings, I has 0800 as the start and 0000 ending. When I switched to 2400 ending time, it displayed correctly. Thanks.

@pgr, how should this be listed on github as a fix?

You can open an Issue and explain the solution there.

Or better, if you can code it into the app (as a validation, for example), you create a new PR with the fixed code.