Users in China unable to access SuitCrm


Im currently using version 7.10. My clients in China issues accessing the CRM , they need to loginto a VPN before they can access the tool. I have spoken to my ISP and they assure me there are no deny rules on the server. I doubt that this has anything to do with SuitCRM as a tool but I thought I’d ask anyway to see if anyone else had experienced this issue and what the possible solution could be. I have disabled the Validate user IP on the system setting but this did not help either.

I would appreciate any help or advice.

Thank you


A few months ago there was someone here on the Forums that was having problems accessing from Iran. But I’ve never heard complaints from China.

What exactly are the issues they’re getting? Can they ping the SuiteCRM server by DNS name? And by IP address? Can they login?


They are unable to login at all. I will request the public IP’s and update ticket.



Attached is what the Users in China get. No error message, just the system does not load. The login page just does not load.



The attachment didn’t work, try putting it on

But a blank screen won’t tell me much, it’s more important to answer my other questions, can you ping by DNS name? Can you ping by IP address?

If you’re getting blocked, it might be because of the place where SuiteCRM is hosted. You could try setting it up in a different place to see if it loads. Or just try one of the online demos.


My ISP is helping to look at this issue as the client can hit the server when doing a Ping and tracert.


I’ll answer here since there more information here than in your new post.

I would try two new directions of diagnosis:

  1. Try hosting SuiteCRM elsewhere, to see if what they’re blocking is not SuiteCRM, but your server, or your ISP. Ask your client to try and access SuiteCRM on the live demos, for example:

  1. For your server, have your client check their browser’s Developer Tools, network tab. Which requests get blocked, and which error is it?
    Blocking rules can be pretty dumb, sometimes it’s simply a filename it doesn’t like.

I always recall when I couldn’t access Experts Exchange from behind a certain filtered network, because the url contained the expression “sexchange”… :ohmy: