URGENT - after upgrading 7.8.13 to 7.8.22 getting Invalid File Reference from attachements in inbound emails

Upgraded with no apparent issue on Saturday.
this morning all inbound emails seems to lose their attachments.
If we click on the attachment from an inbound email we get the “Invalid File Reference” message with no document in the upload folder…
If I look at the database, everything appears to be ok but in the upload folder… it is simply not there.

I am running iis so it is not a security issue
Any idea did the upload folder name changed? i looked in my config file and it appears to be ok.

System is down with orders missing so it is really a bad day! :frowning:


just as a precision
I created an email and added an attachment and sent it outside, the receiver got the message and attachment ok,
AND looking at the sent email I can see and retrieve the attachment fine.

So far I would say it is the inbound email module at fault.

reported on github #6423
the problem is not solved but I revert to the 7.8.13 code manually, since the problem was discovered 48 hours after the upgrade and data was added to the system I could not revert to backups (site and sql data). so I manually copied the code (not the uploaded directory) over the 7.8.22 to go back to 7.8.13
I ran “Quick Repair and Rebuild” and the system appears to be working normally as 7.8.13 again.
I am really surprise this problem has not surfaced before because it is major and 7.8.22 is close to month old…
I tried to find solution but it does not seem to be obvious and the inboundemail.php code has been completely revised.

1 Like

could you please tell me which directory you copied? We are facing same problem in 7.8.22. We updated from 7.8.18 to 7.8.22
Thank you in advance

of course make another backup before proceeding… both data and code
about the code, for my instance, I copied every directories back except uploads which contains all the received files and external documents not related to suitecrm by code (documents files from document module, etc).
i flushed session directory, cache directory, (which I think the later would be flushed with quick repair anyway)
for the root directory I only modified the config file but if you are using soap you might want to bring the old version back of those service files…
I modified the config file to reflect new version and I modified config table to reflect current version.
then I performed quick repair
be aware that you might have to play around the email tables after rebuilding because I had issue with new case creation…
one of the problem was the folder id some were modified for no apparent reason. I also noticed that I now have duplicate in the folder relation table which I still working on, the “function::pollMonitoredInboxes” is hanging some times (quite often) but finally the emails comes in the cases and I think it is related…

I hope you will be able to bring things back, we are operational but as I said I am still investigating on the dammages.
Good luck!

Thank you.
That didnt help us.

I’m just going back to 7.8.18 from a snapshot

snapshot from vm? beware you will loose your upload files… copy them from ill system to the rescued one.
curious, what are the symptoms?

We reverted back to 7.8.18 from 7.8.22. It was a vmware snapshot. We only loose 2 days of work which we were able to reproduce inside CRM between “old” and “new” version. We don’t have problems with uploaded documents.

Nevertheless this problem must be solved.

Next time we will create a clone of the SuiteCRM VM before updating and test all functions including email import after updating inside this clone.

Seems that testing new version after update was not sufficient on our side.

If this is to ever get fixed, an Issue needs to be opened on Github with sufficient detail… if you two can please check if there is one there already? And open a new one if not… thanks.