Upload for upgrade works, but does not appear

I tried to upgrade from 7.3.x to 7.4.3 today.

All my permissions are fine.

I click the browse button and select the correct upgrade file and press upload.

t that point, I get a message saying that the file was uploaded, but in the rectangle saying:
The following upgrade packages are ready to be installed:

I have “None” listed.

It uploads, but is not available to be used for upgrading.

Can someone point any thing out for me that might cause this?

If it is any consequence, I went through all the repair procedures in order to have a clean database before upgrading.

Thanks for any help.



I just wanted to say that I still have not been able to solve this mystery.

The upgrade file uploads just fine. But, it still does not show up, and when I say “next”, it says that I have not uploaded the file yet.

Any help would be appreciated.


Same Problem here.

but the file permission in upload/upgrades/patch is different.
Maybe this is the reason.


Thanks for letting me know that I am not the only one with the issue. Hopefully the SuiteCRM team can help.

WE are stuck for upgrading SuiteCRM until we can solve this issue.

Ideas anyone?



Hello Hyden,

Have you been able to resolve your issue? I have not had any luck yet?

Anyone form the SuiteCRM team able to offer an opinion?



We found am way which word for us:

  1. Delete all files in folder: uploads/upgrades/patch/
  2. remove the specific entry in Table upgrade_history
  3. delete all folder from /cache

after that, we was able to install the update.


This worked for me as well.