Upload fails - 404 for sugar_grp_yui_widgets.js

Hi there,

if I want to import a 42MB CSV-file with quite some data I get an 404-error on my webserver, while SuiteCRM is telling me, that the upload limit is too small. The upload limit is 128MB, post size 256MB - 42MB shouldn’t be a problem. Checked with phpinfo();

The missing file is:

Why is SuiteCRM calling a file, that is not there? How to solve this issue?

Thanks a lot!

If you got that phpinfo from a command-line, that is probably going through a different PHP engine, and a different php.ini. You also need to restart the web server after any changes.

To check the effective values SuiteCRM is using, you need to check form a page served by the web server. An easy way to get this is from Admin / Diagnostics / phpinfo.

However, maybe your upload limit is not the problem.

For the missing file, I would ask two things

  • what is your SuiteCRM version?

  • is this a new install? Any chance your ownerships/permissions might be not correctly set yet? If so, it’s likely you would see a lot of undefined labels showing on several screens throughout the app.

1 Like

Hi, thanks a lot for the fast response.
I checked the limits directly in the right directory.
Double checked via Diagnostics - limits are fine.

I’m running SuiteCRM 7.11.10

yes, the installation is fairly new (Friday), but permissions are fine (other file uploads worked) and everything else works fine. I checked: The file is really missing. It also wasn’t in the installation files.

You can try a few repairs form Admin /Repairs

  • QR & R

  • Javascript Group files

1 Like

Could potentially be an over strict max_execution_timeout as well but the error message is a weird one if that the case (Think that’s the correct var name).

1 Like

Hi I found Javascript Group files - I did the repair, but the file still doesn’t appear in the directory where it should be /include/javascript/sugar_grp_yui_widgets.js.
I also did QR&R - didn’t help either.

max_execution_time is at 120 seconds. Upload-error comes up immediately.

Any clues in your logs?

1 Like

I found the issue throught the SuiteCRM logs.

SuiteCRM itself has an upload limit too. Don’t really understand why, but this definetely is different to most other php-based software which normally uses the php-settings.

Hopefully this will help someone else in the future.
The max upload size is defined in system settings within SuiteCRM.

Sorry, can you please explain exactly where SuiteCRM has this internal limit?

1 Like

sure thing:

“System settings” - “Advanced” - “Maximum upload size:”

Thanks. From looking at the code, I can’t find any place where that value is actually applied… :thinking:

And I read on Stack Overflow that this upload_max_filesize setting cannot be set from code, it has to be done in php.ini. This is starting from PHP 5.3.

So I would conclude that that value in Admin / Settings is not getting applied… are you sure that changing that made a difference?

Edit: I think I know what’s happening - it simply makes a difference to the fact that SuiteCRM uses that value for a comparison, throws an error and stops the process. But it doesn’t change the fact of how big a file you can upload.

Can only tell you: that value did it. After changing it everything worked. php.ini was set to 256M - so that was fine and it only works after updating that value in SuiteCRM.

Your edit might be the right clue.

I opened this