upgrade wizard don't work anymore

We use
Version 7.11.4

on a ubuntu server with root access.

We have upgrade to the current version and it works fine.Now we tried to upgrade to the actual release 7.11.5 but we cannot open the upgrade wizzard. It said time ou (error 500).

we already changed the php settings to max_execution_time : 300 and max_input_time : 300

PHP version 7.2.19 Fast CGI by Apache

We tried already everything. But we can’t upgrade

Check also max_post_size and max_upload_size.

But what I guess is your problem is that you might not be editing the correct php.ini.

You can go in Admin / Diagnostics and select phpadmin. From there you can check which php.ini is getting loaded, and which actual values of these settings your web server is using. So please check if they are like you set them.

Something must be there at apache log

tail /var/log/apache2/error.log

[Wed Jun 05 08:14:56.775632 2019] [fcgid:warn] [pid 56325] mod_fcgid: process 63533 graceful kill fail, sending SIGKILL

Nobody with an idea?

Did you try my last suggestions? What did you find out?

Here are the entries in the php.ini. The datas I got from the diagnostics in SUITE CRM

max_execution_time 3600
max_file_uploads 20
max_input_nesting_level 64
max_input_time 120
max_input_vars 1000
memory_limit 512M
post_max_size 36M
upload_max_filesize 35M


Try renaming your “upload/upgrades” directory to something else (you can delete it later if there are no problems).

It will get re-created when you try to upgrade again, and renaming it will clear out any left-overs from previously failed upgrades.

did it. But stay the same.

Here the entry in upgradeWizard.log:
Mon, 10 Jun 2019 14:53:53 +0000 [UpgradeWizard] - setting session variables…
Mon, 10 Jun 2019 14:53:53 +0000 [UpgradeWizard] - -----------------------------------------------------------------------------
Mon, 10 Jun 2019 14:53:53 +0000 [UpgradeWizard] - Upgrade started. At start.php
Mon, 10 Jun 2019 14:53:53 +0000 [UpgradeWizard] - at unlinkUWTempFiles()

Here the error.log:
[Mon Jun 10 14:55:53.487922 2019] [fcgid:warn] [pid 123595] [client XXXXXXXX] mod_fcgid: read data timeout in 120 seconds, referer: https://XXXXXX.com/index.php?module=Administration&action=index
[Mon Jun 10 14:55:53.487978 2019] [core:error] [pid 123595] [client XXXXXXXX6] End of script output before headers: index.php, referer: https://XXXXXX.com/index.php?module=Administration&action=index

Here the proxy_error.log:
2019/06/10 14:55:53 [error] 121934#0: *132638 upstream timed out (110: Connection timed out) while reading response header from upstream, client: XX.XX.XX.XX, server: XXXXX.com, request: “GET /index.php?module=UpgradeWizard&action=index HTTP/2.0”, upstream: “https://XX.XXX.XX.XXX:7081/index.php?module=UpgradeWizard&action=index”, host: “XXXXXX.com”, referrer: “https://XXXXXX.com/index.php?module=Administration&action=index

Increase this value

max_input_time 120

it seems it’s not enough. Remember to restart web server.

But it seems quite slow, maybe there is some problem degrading the performance of your server…

If you use plesk, go to Apache & nginx Settings for your website, and add in the https section :

FcgidIOTimeout 3600 FcgidBusyTimeout 3600 FcgidProcessLifeTime 3600