Upgrade Wizard 7.11.2 freeze with error

Any help will be helpful. I tried to upgrade from Version 7.11.2 to 7.11.3 from admin panel Upgrade Wizard. When I press Upgrade Wizard display gets freeze (for approximately 5 min) with error - “Could not connect to the database. Please refer to suitecrm.log for details (0).
Fatal error: Uncaught Exception: Could not connect to the database. Please refer to suitecrm.log for details (0). in /home2/htwoopur/public_html/SuiteCRM/include/utils.php:1775 Stack trace: #0 /home2/htwoopur/public_html/SuiteCRM/include/database/MysqliManager.php(322): sugar_die(‘Could not conne…’) #1 /home2/htwoopur/public_html/SuiteCRM/include/database/DBManagerFactory.php(150): MysqliManager->connect(Array, true) #2 /home2/htwoopur/public_html/SuiteCRM/include/entryPoint.php(182): DBManagerFactory::getInstance() #3 /home2/htwoopur/public_html/SuiteCRM/index.php(47): require_once(’/home2/htwoopur…’) #4 {main} thrown in /home2/htwoopur/public_html/SuiteCRM/include/utils.php on line 1775”
After approximately 5 min website is coming back to work by itself.
Is it possible to upgrade manually to the new version? Or how could I fix this issue with Upgrade Wizard from admin panel?

Is your database running on the same server as SuiteCRM app?

You might need to increase some values in your php.ini:

memory_limit (make it 256MB or more)

But this looks like a server problem, or a database problem, not a SuiteCRM problem…

Is your database running on the same server as SuiteCRM app? Yes, it is the same server.
I changed:
memory_limit 256Mb
max_execution_time 120
max_upload_size 128
max_post_size 128

any other ideas?
just to confirm that the app runs with no problems
the issue appears only in Update Wizard

By my understanding, I receive:
[FATAL] Could not connect to DB server localhost as varr_sugar. port : User varr_sugar already has more than ‘max_user_connections’ active connections

I contacted the support to increase max_user_connections (at this moment 15)
support told me that is not possible for me to increase max_user_connections - instead I have to optimize the DB

Any clues on how to fix this issue?

Try renaming your “upload/upgrades” directory to something else, so that you start the upgrade from a fresh state. You can delete that directory later if everything goes well.

“upload/upgrades” renamed - did not help
when I press Upgrade Wizard new folder “upgrades” appears. I still have the same problem with “max_user_connections”.
There is any way to change or to limit same time max queries for a user in SuiteCRM?

One more thing: I noticed that the error related to “max_user_connections” appears only at account administrator which run Upgrade Wizard.
I have 2 administrator accounts - if I run Upgrade wizard from one account this got freeze for 5-7 min. in the same time another administrator account is working with no problems.

CORRECTION: I renamed both “upload/upgrades” from the cache too. at this moment “Upgrade Wizard” starts with no issues but when I press the “Next” button I have 405 error.

Ok, you’ve made progress. Now let’s work on that 405 error, what exactly does it say?

I fixed 405 error - I changed permissions for folders and files in (cache upgrade) and (upgrade) to 775.
at this moment a can upload the upgrading file. I am stuck at upgrade file - zip file is uploaded but I still have the message “Upload a package before continuing.” pressing the “NEXT” button gives no response. also in the same window, I have the message “The following upgrade packages have been installed: ( SuiteCRM patch 7.11.3 04/25/2019 10:47 None)” this can be deleted.

You need to do the full ownership/permissions fix, not just change a couple of directories.

Do you know which user your web server is running under? That’s what you need to use for the chown command.

You can see the user name in Admin / Schedulers, at the bottom of the table, inside the recommended crontab command.

I checked the ownership/and group is correct

this is print screen

The problem was in 7.11.3 update
I downloaded 7.11.4 update - installed with no problems.

Thank you!

Not sure if this is exactly the same but I had various errors in my suitecrm.log and apache log and it seems that the virtual machine I was running just needed a little extra memory. I had been working successfully for quite some time with 3GB RAM (total machine) but then started hanging on login and upgrade wizard - interestingly only from some clients while others were fine. Increasing the memory available to the VM to 4GB immediately seemed to fix the problem.

I had this exact problem with upgrading 7.11.2. I kept getting stuck on the system check and timing out. I tried permissions and deleting upgrade folders, etc.

Nothing worked, then I did a quick repair and rebuild. Turns out the database was not sync’d with vardefs, not sure if this was left over from the last upgrade. Anyway, completed the quick repair and rebuild and the upgrade proceeded normally. Just in case anyone else has this problem you can try this too.