Upgrade to 7.9.0 failed

Hello All,

I upgraded from 7.5.3 to 7.79 to 7.8.4 and then to 7.9.0

The system worked properly for 7.79 and 7.8.4 but the 7.9.0 upgrade failed, pages would not display properly so I rolled my installation back to 7.5.3 from a backup.

Now I am trying to apply the 7.79 and 7.8.4 upgrades but they already show as installed. What changes do I need to make in order to run the upgrade?



Can you please describe better what you did when you " rolled my installation back to 7.5.3 from a backup"

Did you revert to a snapshot on a VM? Or copy files? Or copy both files and MySQL database?

I restored the database and copied files back into the folder.

I was able to delete the zip and log files for the previous upgrade from the upgrade/patches folder, however when I do the upload it just doesn’t take. The file uploads and a log is started but can’t continue the wizard as it does not see the file.


Some people get this because of their PHP version; or maybe because of the PHP modules (mainly the zip module) that are required.

Other times it’s the ownership/permissions/sticky bit on the uploads directory.

Other people had this because of a corrupt zip file (you can use unzip to test it), or re-download.

Other people had the wrong kind of package (installing a full version instead of an upgrade)

… I hope these pointers can help hunt down your problem.

Same symptom; upload finishes yet the wizard does not see it.

After the upload I see;

SuiteCRM-Upgrade-7.5.x-to-7.7.9.zip has been uploaded.

The following upgrade packages are ready to be installed:
Name Type Version Date Published Uninstallable Description

Permissions 755 doesn’t mean anything without knowing the ownership, and which user your web server is running under…

Please check your PHP modules, especially zip module.

And then share install.log or upgradeWizard.log, whichever is getting written to at the time of he upgrade. Maybe I can get some clues from there, I don’t know… I’m running out of ideas to try…

Cannot add an attachment to this post. The Add File does not do anything when clicked.
Log is available here: https://www.dropbox.com/s/wkjlnqf3itw0f0e/upgradeWizard-partial.log.txt?dl=0

What is your PHP version?

Apache Version 2.2.31
PHP Version 5.4.45
MySQL Version 5.6.35

Well, there you have it, you need at least PHP 5.5 for this version of SuiteCRM:


If you can’t upgrade PHP, you can look for php_error.log or try to play with display_errors to see if you can get extra information about what’s breaking. Version 5.4 is sensitive to “strict errors” issues with SuiteCRM, there are other threads in this forum with your problem and they’re also using PHP 5.4

ESL While this certainly could be the issue the upgrades from 7.5.x to 7.7.9 and 7.7.9 to 7.8.8 ran properly before. I have requested an upgrade of PHP to 5.5 but I don’t think it is likely to resolve this issue.


You’d be better off with PHP 7, works great with SuiteCRM and is much faster and safer.

If that doesn’t work just go back through this thread and examine some of the ideas that you didn’t examine yet, there were quite a few left behind…

Good luck!

Upgraded to PHP 7, same result. File uploads but is not seen within the wizard.