Upgrade got freezed while "Copying Files"


my i just tried to Upgrade my SUITECRM to the latest Version.

Is first tried to do the upgrade on a dev server, everything worked well.

I startet the Upgrade on the production system and everything worked well since the screen copying files runs and runs… after about 10 mins i broke up. The Same Server my Dev instance is running, the copying files took about max 1 min.

I think there went something wrong, but: I can see some system improvements, cause the reports now are working correct for example.

I was not able to finish the Upgrade. But: my system is running and shows me i have the Version **Version 7.11.19

But the upgrade was not complete done.

What should i do now? Can i uninstall the Upgrade and do it again?

I have a Backup of the database and the complete files of the CRM, shut i just set up a new instance with the backup and start to upgrade again? Is the Upgrade updating the database too?

Thanks for your advices, really looking forward.

If the “About” says you’re on the new version, you are, at least I’ve seen this happening before, even if the upgrade didn’t seem to finish the final stages.

I would just do some tests to make sure everything is working fine.

If you retry any upgrades that fail half-way through, always clear the cache/upgrades/temp directory.

Thank you.

What i can see, is a small difference in the Report Module:
Dev System:
(Looking better)

Live System
Without Stylesheets for the last sum line?

Do you have any idea?

Something I don’t understand: which version were you upgrading from, and which version were you upgrading to?

When you say you now have 7.11.9, was that what you were upgrading to, or where you were before?

I upgraded to 7.11.19 (latest Version?)

I upgraded from an older version ~ 1 year old (Download and initial installation was around 1 year ago)

Ok, so I think you should consider yourself upgraded, if the About box says 7.11.19.

Any other problems, deal with them separately as potential bugs/issues. Try a few repairs from Admin / Repairs, that helps.

Thank you for your fast response.

I found a bigger issue in the email module.

When clicking on an account or contants mail adress the relationship is not set automatically:

After opening the List of email templates i am not able to pick one, cause when i click on the name of the Template nothing is happening.
When i click on the Erase icon to close the Window this screen is shown:

Actually we are working productive on the system and i do not know, if i can get this system running, do you or someone else have some quick advices? Thank you a lot.

Look at the discussion about email form.


thank you.

I changed the Permissions that way, the CSS Problem in the Reports is now fixed.

But the Mail Client is not working, so the changes did not affect the functionaliy.
An other Issue i found, was that my workflows that where sending mails bases on sheduler are not working actually. Workflows triggered by save are working.

/var/www/html/suitecrm$ sudo chmod -R 755 .
/var/www/html/suitecrm$ sudo chmod -R 775 cache custom modules themes data upload
/var/www/html/suitecrm$ sudo chmod 775 config_override.php 2>/dev/null


I tested it in versions 7.10.22 and 7.11.18. It worked for me.
Did you do “Quick Repair and Rebuild” after change permissions?
Do you have messages about errors in log file?
I see that that field “Body” don’t support html editor. Maybe you should save the user record again.

Did you configure cron on your server?

Hello, Cron is configured and the Workflow without “Send Email” as Action are working well.

I think that i have 2 Problems:

  1. Outbound E-Mail Account configuration crashed during the update, i hope i can fix that today easily.
  2. My Popup Windows with the search/list view of email templates or account, or quote etc. are not working. I can see the List but when clicking on an entry nothing happend.

Error Log Level: Fatal

This is what is written down there (just the last lines)
Wed May 26 09:40:08 2021 [1547513][3f547067-f5c7-94ce-d45f-600e8218fd16][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Wed May 26 11:04:21 2021 [1985390][32d40667-cd32-e356-4e56-6088344d9083][FATAL] SugarPHPMailer encountered an error: Invalid address: (to):
Wed May 26 11:06:29 2021 [2023019][32d40667-cd32-e356-4e56-6088344d9083][FATAL] SugarPHPMailer encountered an error: Invalid address: (to):
Wed May 26 11:08:33 2021 [2023019][78039cf5-6f87-6c10-735a-5e996ae0432f][FATAL] SugarPHPMailer encountered an error: Invalid address: (to):
Wed May 26 11:21:13 2021 [2076602][921a13ee-d342-ba44-5d26-5f60b0a51493][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Wed May 26 11:37:00 2021 [2200861][78039cf5-6f87-6c10-735a-5e996ae0432f][FATAL] SugarBean::populateDefaultValues $field_defs should be an array

Any Ideas?

An Other Question:

Does the Update affect the Database?

Can i in the worst case roll back easily with just rolling back the complete files of the crm system?

Look at errors in console of browser.

I think that the error wrote the Workflow when call “Sent Email”.

From which version and to which version did you update?

When opening the Mail Client this errors where shown:

After selecting an Template this was shown:

The Subject and attachment of the Template was loaded, the body is empty.


thanks for your educated advices.

Is downloaded and installed the Version at the 16.04.2020. Actually i am not sure which version was the actuall Version on that date.

And i upgraded to the Version: 7.11.19

Maybe it’s problem with file .htaccess. You can do: Admin -> Repair -> Rebuild .htaccess File.

I did the Rebuild of the htaccess and did a quick repair and rebuild too again after that.

Now this is the actual error:

Template is been loading but without the Body.

My WYSIWYG Fields (Textareas with html format) are simple Text Inputs too now.

Maybe there is something gone wrong with the HTML Editor?

When i am just clicking on a email adress from the contact detail view, this is logged on error log level: Error

Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] EmailController::action_getFromFields() expects an outbound email id as stored option of inbound email (d7dbef2f-1db0-fb85-9643-60017cff58bd) but it isn’t valid.
Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] EmailController::action_getFromFields() panic: An error occurred! (203)
Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] Incorrect “replay to” format found: xxxxxx@xxxxx.de
Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] EmailController::action_getFromFields() error: 205
Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] Signature html not found!
Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] Signature plain text not found!
Thu May 27 11:18:39 2021 [169561][78039cf5-6f87-6c10-735a-5e996ae0432f][ERROR] EmailController::action_getFromFields() is Panicking: Reply-To address is not filled.

It’s problem with loading files to frontend only. Sorry, I can’t see you installation. The file vendor/tinymce/tinymce/tinymce.min.js is loading for version 7.11.x .