Upgrade from 7.7 Beta 1 to 7.7 Beta 2


I upgraded the system from Beta 1 to Beta2 to test the new UI. Upgrade seems to be completed without problems, but when I try to change the theme to the new UI, as seen in the attachment, UI is not working as desired. What can be the cause of the problem?

Thanks and regards.


Try setting your permissions - looks like the CSS styling hasn’t loaded in correctly.

cd /where/your/suitecrm_folder/is/
sudo chown www-data:www-data -R .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Now the group and owner (www-data:www-data) could be different on your server.

You should also clear your browser cache if you are changing themes.



I changed the permissions settings and the problem was solved.

I’ve done the upgrade on two CRM, one I’ve upgrade from RC 2 to 7.7. I seem to have a problem with the calendar and doesn’t show properly. On the second CRM, I’ve upgraded from 7.6 to 7.7 and I see the columns in the calendar. I’ve tried to do repair/rebuild and all repair options and still have the same problem. Have any ideas on what I can do to solve this issue?

I have exactly the same problem when updated from 7.6 to 7.7: Calendar is not showing at all. In addition, i tried to add Calendar as a dashlet to display in Home. The result is that not only the calendar is not showing, but now ANY dashlet is showing, I get in both Calendar Page and Home Page a completly blank space, the Navigation and sidebar are working normally.

It will be appreciated any help to solve this problem, Thanks in advance.

Additional Note: I realized that the Problem persists even changing back to Suite R Theme which was showing the calendar and working properly. So Now, both themes are with this issue.

I checked permissions and cleared browser cache as well.

Permissions 775 are only for the Folders indicated in documentation (cache, date, custom, upload, themes) or 775 is also for the Files inside these folders?

Thanks again

I saw that they noticed the problem and it should be solved in the next version.