Upgrade from 7.13.0 to 8.3.0

I’m upgrading my Suite CRM from 7.13.0 to 8.3.
But it doesn’t work.

I have 2 folders under /var/www/html/.

  • Folder suitecrm7 (old version)
  • Folder suitecrm8 (upgrade version).

I copied the folder of 7.13.0 version (suitecrm7) into the 8.3.0 upgrade version folder (more specifically in /var/www/html/suitecrm8/public), and renamed folder to legacy, according to the docs.

Then i have my upgrade in
and my legacy in

Before start the migration i set the apache httpd.conf to redirect requests to /var/www/html/suitecrm8. (I don’t know if it is correct).

Then i ran the cmd below (inside suitecrm8 folder):
./bin/console suitecrm:app:setup-legacy-migration

It is required to set site_url in config.php file inside /var/www/html/suitecrm8/public/legacy
I set the value of site_url to https://myip/suitecrm8/public, according to the docs.

I also set RewriteBase as RewriteBase /crm/public/legacy in .htaccess file inside /var/www/html/suitecrm8/public/legacy.

After i ran the command below:
./bin/console suitecrm:app:upgrade -t SuiteCRM-8.3.0

And finally i ran the command below passing the version name (SuiteCRM-8.3.0) when neeed.
./bin/console suitecrm:app:upgrade-finalize

At the end of upgrading, the suitecrm doesn’t work and i verified that doesn’t exists an index.php inside root folder.

documentation that i followed


I appear to have the same issue, just a directory listing. I have been on an update/upgrade mission as well. Hit a few bumbs on the path but got as far as 7.13.4. I have now followed the instructions as per the link here:


I was prompted to adjust URLs in 2 files which I have done and now I should log in to the v8 CRM. Unfortunately I only see a directory, there is no index.html or php. What is the correct URL or is there a fault in the procedure documented ?

Kind Regards
Jan P.

Just to add, I had no errors showing and the system has Apache 2.4.56 and PHP 7.4.33