"Undefined" text

I see a lot of “undefined” messages pop up. Generally when saving work. It feels like there should be some type of communications. But there hasn’t been anything added and the default is just to say “undefined”.

If this is the case. Should I start tracking these to help out? And provide feedback on what feels should go in there?

Let me know! Would love to help out as much as possible!


Hi Dale,

The “Undefined & Fail” messages mean a permission issue. The web-server user (typically www-data, apache2, or something similar) doesn’t have the proper permissions on the website directory.

Run the chown & chmod commands in the installation procedure, then run a quick-repair. It should fix any of these issues.

Thanks for getting back to me. What do you mean by this? Sorry if that is a rookie questions.

Actually let me try some of the recommendations from another on of your threads first.


I have changed the permissions and did the rebuild. I am still seeing the issue. It’s not breaking anything. I guess I can live with it.

Try this.

Delete cache/jsLanguage/en_us.js
Refresh a page… a new one should be created. If not. Log out and re-log in again.
When you see a new one, change the permissions to 777
Then refresh a page.

See this http://forums.sugarcrm.com/f3/getting-undefined-loading-message-51370/

1 Like

This is adapted from a file I found on the web. I updated it to include all folders that Sugar says should use 664 and 775. (Not 644 and 755.)

Put the file in your CRM root and run it in a browser.

See http://support.sugarcrm.com/04_Find_Answers/02KB/02Administration/100Install/Required_File_System_Permissions_on_Linux/

I am posting this a second time because I did not zip the file the first time so it did not attach.

is a permission problem please check your permission do it as show in the Installation wizard

Just an FYI. This was resolved when I did a complete reinstall.

The delete “cache/jsLanguage/en_us.js” worked for me.
Thank you.

1 Like

I had the same problem and noticed that my file permissions on the ‘Cache’ directory changed and need permission to be set again after installation. Reset permmissions and it worked a charm.

1 Like

Here is the best way to resolve this.

1.) Make Sure Your WHOLE “Cache” folder has the permissions of “777” (see image below)

2.) Then click into that Cache folder and change the permissions to the 'jsLanguage" folder to “777” (See Image below)

3.) Now click into that folder (jsLanguage) and delete the “en_us.js” folder.

4.) Finally go to your crm system and delete your browser cache or hold down control key and tap the F5 key. You should now see it working just fine.

1 Like

Hello all,

if nothing helped, check if the folder which is set in RewriteBase of your .htaccess matches the root folder of your instalation.
This solved it for me.


1 Like

You should never need to set 777 on cache, 775 is suffice.

This problem has plagued Suite users for years now. I’m surprised the development staff has not addressed it by now. And it is actually a hold-over issue from SugarCRM.

Instead of bringing out new features, I’d much prefer that SuiteCRM spend this year either:

  1. fixing bugs from the old Sugar codebase


  1. Re-writing as much of the codebase as needed to remove the vestiges of Sugar and some of its arcane procedures.

The second choice would be a large undertaking but it would make Suite a much more viable product in the CRM marketplace. It will probably have to be done sooner or later… so maybe ‘sooner’ is better.

“There is never enough time to do it right, but there is always enough time to do it over”

Hello guys,

I’m kind of new in this thing so please help me!!

Im having tons and tons of “undefined” messages (and everyday there are more new)

I’m using MAMP to run SUITECRM as localhost.

I dont know much about “cache” setting permissions or whatever you’ve been talking about in here, but this is becoming very anoying… So please some help for this rookie?

Thank you very much!

This is is why people who have zero knowledge of computer systems should not run CRM systems on their own but should use a hosted plan… some web hosts will install and manage 3rd party software for a small monthly fee.

If you don’t know how to use your file manager (on either PC, Mac, or Linux) AND don’t understand permissions AND how to change them, there is not much we can do to help you because there is a learning curve involved… you need to do your research and learn on your own… it is not that hard.

What I might suggest you do is to delete your current local install of SuiteCRM and reinstall but this time use a self-contained ‘box’ from https://bitnami.com/stack/sugarcrm and perhaps their installer will have all the permissions set for you.

I’m convinced that your problem is that you have a lot of files that are NOT set to 775 and you might have some directories set to 770 which will prevent Apache from even reading anything in it.

Sorry this is not more helpful. Maybe someone can point you to a good tutorial or video on file and directory permissions for your OS and how to change them.

1 Like

Thank you dev77 for your help, I know there are many reasons why a noob shouldn’t try to do this kind of stuff but after trying many CRM I found out the only one that have what i need (or like) is SuiteCRM…

I know there is an option to pay for hosted CRM but I’ve had bad experices with web CRM… Thats why I’m trying to run a local one.

I didn’t knew this bitnamy thing, many thanks for the info!! Now I have a question, is it possible to move my database from mamp to this? I really dont want to loose all the info…

Thank you

Yes you can get all the records from the MAMP system to the new bitami install.

It is an involved process requiring using phpMyAdmin to create a ‘dump’ of your old database and then using it to delete the tables in the new database and loading to dump file to it… and there are some other config items as well.

I’m sure there are a ton of tutorial on how to move a SugarCRM database from one install to another that will give step by step instructions. There may even be one for SuiteCRM out there.

It is a pain to do but I’ve done it many times and if you follow all the steps it will work fine.

Let us know if you find a good tutorial or video on how to do this.

Actually it was very easy, I installed SugarCRM from Bitami… Then I went to phpmyadmin in MAMP, exported the sugarcrm database as “dump.sql” then went to phpmyadmin in Bitami, deleted the “bitami_suitecrm” database, imported the “dump.sql” database and renameit to “bitami_suitecrm”

Didnt even need to restar the server :slight_smile:

Thank you very much! Works like a charm now!