Undefined showing in Studio and Module Builder

It looks like its labels, which is totally weird. Screenshoots… Below

Also, from the Studio, Layouts View, when I choose Save and Deploy, I get a box labelled “undefined” with contents “undefined”, and a Close Button. Unfortunately nothing is saved, and nothing is deployed.

I’m not sure where to start troubleshooting.

Here is my installation script I am following.

Note: Using linux mint

–Update all the software packages:

sudo apt-get update
sudo apt-get upgrade

–Install the required software stack for SuiteCRM. This includes the LAMP stack and PHP modules.

sudo apt-get install apache2 apache2-utils libapache2-mod-php libpcre3 libpcre3-dev zlib1g zlib1g-dev mariadb-server unzip

sudo apt-get install php
sudo apt-get install php-cli
sudo apt-get install php-curl
sudo apt-get install php-common <–already the newest…MX Linux…Linux Mint
sudo apt-get install php-intl
sudo apt-get install php-json
sudo apt-get install php-gd
sudo apt-get install php-mbstring
sudo apt-get install php-mysqli
sudo apt-get install php-pdo_mysql <–unsable to locate package…MX Linux php 7.4…Linux Mint
sudo apt-get install php-openssl <–unable to locate package…MX Linux…Linux Mint
sudo apt-get install php-soap
sudo apt-get install php-xml
sudo apt-get install php-zip
sudo apt-get install php-imap
sudo apt-get install php-ldap
sudo apt-get install php-mysqli <—Already installed …Linux Mint
sudo apt-get install php-pdo_mysql <— Unable to locate … Linux Mint

–Start the Apache service

sudo systemctl start apache2 <—MX Linux wont start apacheunless Systemd enabled at boot

–Start MariaDB service and enable Apache and MariaDB

sudo systemctl start mysql
sudo systemctl enable apache2
sudo systemctl enable mariadb

–Secure and harden MariaDB.

sudo mysql_secure_installation

–Edit php.ini located at /etc/php/7.4/apache2/php.ini

upload_max_filesize = 8M             <--Note this must be > 6M  as 6M gives error.
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT & ~E_NOTICE & ~E_WARNING

–Restart the Apache service.

sudo systemctl restart apache2

–Create database

sudo mysql -u root -p
MariaDB [(none)]> CREATE DATABASE suitecrm;
MariaDB [(none)]> CREATE USER ‘larry’@‘localhost’ IDENTIFIED BY ‘secretpassword’;
MariaDB [(none)]> GRANT ALL PRIVILEGES ON suitecrm.* TO ‘larry’@‘localhost’;
MariaDB [(none)]> exit;

--------------------------- this block is for Suitecrm7------------------------------------
–Download the latest SuiteCRM files
Create a directory here /var/www/html/suitecrm

– Unzip the downloaded file into the suitecrm directory
– Open a root terminal in the suitecrm directory
– Assign appropriate permission to the unzipped folder

sudo chown -R www-data:www-data /var/www/html/suitecrm
sudo chmod -R 755 /var/www/html/suitecrm

–Open your internet browser and enter URL:


–complete installation

-------------------------------end Suitecrm7 block -----------------------

-----------------------------this block is for Suitecrm8----------------------------
–Say prayers because this is harder.

–Create crm folder located at /var/www/html/crm

–Download and unzip Suitecrm8 into the crm folder www/var/html/crm/

Open a root terminal from crm folder. Set permissions for crm folder.

find . -type d -not -perm 2755 -exec chmod 2755 {} ;
find . -type f -not -perm 0644 -exec chmod 0644 {} ;
find . ! -user www-data -exec chown www-data:www-data {} ;
chmod +x bin/console

Configure URL re-writes . Note to self. This step is specific to Linux mint and probably wont work elsewhere.

sudo a2enmod rewrite
sudo systemctl restart apache2 <— repeat this everytime you make a change in php.ini or apache2.conf

–Source of info. Apache mod_rewrite in Ubuntu/Mint - Alex Mansfield <–works but I didnt use.

–or -create this file. /etc/apache2/sites-enabled/crm.conf

–insert following

#<VirtualHost *:80> <—doesnt work without the #
DocumentRoot /var/www/html/crm/public
<Directory /var/www/html/crm/public>
AllowOverride All
Order Allow,Deny
Allow from All
Require all granted

I cannot get the blog to show the last two lines above. I have no idea why these are not showing. They are visible in edit mode.

–restart apache

sudo systemctl restart apache2

–To start install, enter this address into browser

http://localhost/crm/public/#/install <------this works
http://localhost/crm/public <------this works

–Click on configuration ← If you dont, you get a misleading error message.
–Fill in the form with

URL = https://localhost/crm ← Dont use https://localhost It gives errors.
DataBase User = larry ← Name and pw combo doesnt work
Password = secret password
Host name = <–Use of name localhost is not supported yet
Database Name = suitecrm
DataBasePort -3306 ← This is default for mariadb and mysql

Application Admin Name = admin
Admin User password = secret password

–Change log out cookie lifetime from 0 to 100000000

session.cookie_lifetime = 100000000


Hi @larry,

The labels are often caused by the wrong pathing in the .htaccess under the rewrite rules found here;

For example, as seen in this S8 release in public/legacy/.htaccess; (S7 Different file path same problem)

RewriteEngine On                                                                                                        
RewriteBase /crm/SuiteCRM-8.0.1legacy/
RewriteRule ^cache/jsLanguage/(.._..).js$ index.php?entryPoint=jslang&modulename=app_strings&lang=$1 [L,QSA]
RewriteRule ^cache/jsLanguage/(\w*)/(.._..).js$ index.php?entryPoint=jslang&modulename=$1&lang=$2 [L,QSA]           

The 2nd line;
RewriteBase /crm/SuiteCRM-8.0.1legacy/ is missing a slash and part of the path causing it to point incorrect giving broken language labels.

Simply adding the /public/ should resolve the issue;
RewriteBase /crm/SuiteCRM-8.0.1/public/legacy/

In S7 the file will be found in the root of your S7 install and may only need the slash added.

Let me know if this resolves any of your issues and whether the failed redeploys continue also!

1 Like

Yay! Which is shorthand for its working now.

As soon as I clean up my notes, I will repost them as a guide for Linux Mint installation… There are several differences…


1 Like