undefined message comes instead of loading for all the modules

undefined popup comes instead of loading message when click on any of the module and also in studio->module->layout some undefined layouts are visible

i have check in the community previous forums stating its permission issue but i tried all the permission not working for me

please find the screenshot

Do Repair and rebuild and set the permission . it should work then.

any recommended permission which i need to share


Set 775 permission for custom, modules, cache and log files.

You can set following permissions :
directories to 775 and files to 664.

i have did the same for custom cache module and logs buts its still not working
i think it picks from cache ->jslanguage directory?

Hi arpit,

Main Issue is Javascript is not loading … so only.

  1. Delete the Browser cache.
  2. As u said you already tried with 755 AND 644 try with chmod -R 777 /rootdirectory (though it is not recommend), if you are using ubuntu…
  3. Now Do Quick repair and Rebuild…
  4. Repair JS files.

I think it will work for You…

so i need to delete my brower cache history as well as suitecrm cache folder
i am using justhost webhoting site


Don’t delete the cache folder…

first try with browser cache only…

i delete the browser cache then rebiuild and then repair js
i am using crome browser now when i click on any default module then its show me blank screen

Give permission and then refresh ctrl+F5 … it should work

not working

please find the url

username: admin
password: admin123

sounds like either the permissions are well off. but if you have 777 the whole dir it wont be that anything in the php error log or the sugarcrm error log ?

sugarlog is empty and attaching the php error log noting seems related to this problem

having a look at the instance it looks like permissions. there is a large amount of errors in the developer console (F12 in firefox). looks like it cant access certain files. there are 44 errors in the developer console.

you will need to update the permissions and the ownership of the files. the permissions should be set to the following.

chmod -R 755 .

chmod -R 775 cache custom modules themes data upload config_override.php

The ownership depends on the setup of the server but for most the following would be correct.

chown -R www-data:www-data .

You will also have to update the config file with the dir and ownership settings. again this could be different for your instance depending on the setup.

'dir_mode' => 1517,
'file_mode' => 420,
'user' => 'www-data',
'group' => 'www-data',

after that repair and rebuild and all should be fine.

Hi Ian,

can you explain thsi thing, i didn’t understand what actually it is…

chown -R www-data:www-data .

i have put the same configuration what you suggest but still no success

please find the relevant attachment


This changes the user and group for all files and folders within the current folder. so it would change the user and group of all files and folders within SuiteCRM


you are still getting errors on this. the screen shots still show some files which are not 755/775. so in developer tools you are still getting forbidden errors.


1 Like

their was an permission issue in the cache/include directory and subdirectory

its working now … :slight_smile: :slight_smile:

Thank you…

1 Like