"undefined" labels all over the place

Dear community,

On the SuiteCRM I do see “undefined” labels in many occasions. Especially, all dialogs only show “undefined” for the labels and on the buttons. It looks like a language file issue to me. On the other hand, I am using the English default.

This has been the case since the clean installation.

SuiteCRM Version 7.2.1
Sugar Version 6.5.20 (Build 1001)

Thank you for any kind of guidance.
Best Regards


“Undefined” labels is regularly a permissions issue

For permissions, we recommend the commands:

sudo chown -R <user>:<group> .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Replce and with your Apache/IIS user and their group.

i.e: Ubuntu would usually be:
sudo chown -R www-data:www-data .
and centOS would usually be:
sudo chown -R apache:apache .

After setting these permissions, run a Quick Repair & Rebuild in the CRM, and run the permissions commands again.

The “undefined” labels should hopefully have been replaced with the correct values.


Thank you for your reply. I started to follow your suggestions and then struggled.

I have ftp access to the Apache Webserver only, no command shell access.
All mentioned folders had already been set to 755, owner being the ftp user.
config_override.php is now set to 775 (previously 644), owner being the ftp user.

Did I get you right that I somehow have to change the access rights to all remaining files and folders to 755? and make the PHP-user own all crm-suite files on the server, correct?

  1. Is it really necessary to make such big adaptations just to see some labels?
  2. Doesn’t this open quite a big door in terms of security?

Thank you very much for further guidance

Best Regards

I did all suggested here, each step, but I still have the “undefined” labels.

There is not problem in alerts an popups, are two options and is easy to figure out the right option, but in reports, all labels are in “undefined” and I do not know what mean each option.

Please, another way to solve this!!

Have you run Quick Repair and Rebuild? (Admin->Repair>Quick Repair&Rebuild)
If at the bottom of the screen you are prompted for some action you have to execute it and run Quick Repair and Rebuild again.
Once done reset files and folder permissions again

You also should edit default_permissions in config.php

Additionally you may have to clear your browser cache.

I am also facing the same issue in KReports… suitecrm version is 7.4.3 and PHP is 5.5 . I have tried the permissions and done the quick repair also. But it is not working .Any solution?

I have same problem but no solution yet :frowning:

Possible that the ‘RewriteBase’ value in your .htaccess in the CRM directory is pointing to a different directory than the name for the SuiteCRM directory.

This can happen if you move location or change the directory name.

It can cause undefined labels in other areas.

Hi, same problem here:

anyone have any ideas?



Does your .htaccess has correct rewritebase path ? and also
do check permission for cache/jsLanguage/YOURMODULE/en_us.js