Undefined index: DO_NOT_CALL

Hi,

I tried to install SuiteCRM 7.8.3 then i noticed when i clicked on the Leads then add the “Do Not Call” Column it wont allow me to tick the radio button next to it.
That will give me an error below:

Notice: Undefined index: DO_NOT_CALL in C:\xamppcrm\htdocs\suitecrm\include\InlineEditing\InlineEditing.php on line 360

SuiteCRM 7.8.3
Windows Server 2008 R2
PHP version 5.6.30

Kindly help me if i’m doing it right or am i using it the wrong way.

Have you tried Admin/ Repair / Quick Repair and Rebuild?

yes i have tried it, even reinstalling the suitecrm.
I also tried it on the website Demo page and nothing is happening when i update the Do not call column.
Hope somebody can help me with it because that is the only issue left before we use the suiteCRM and this tool is very good.

Can you try reproducing that bug on the Softaculous demo (better than the SuiteCRM demo, because this one gives you admin access so you can go into Studio)?

https://www.softaculous.com/demos/SuiteCRM

Maybe it’s a general bug for everybody, not a problem in your system…

In addition to trying to find if there is a problem you may, for the time being, try the following to avoid getting warning messages. There are two ways to do it:

  1. Edit php.ini (the location and the way you can modify it depends on you system)
    change it to:
    error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT & ~E_WARNING

  2. Edit index.php (in the SuiteCRM main folder)
    Add the following line after the first line which should be: <?php
    error_reporting(0);
    You could also add the following line:
    ini_set(‘error_reporting’, E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT & ~E_WARNING);

i tried it and it give me connection error.

@amariussi
I have updated both file and the error now is just saying “undefined”
i still cannot tick the do not call radio button.

From what you say it seems that you may be also experiencing permissions issues.

But since I am not enough familiar with Windows installations of SuiteCRM I may be completely wrong. Sorry but I can’t help.

Will it be a permission issue on the folder where suitecrm is located? or a permission issue on suitecrm?
Also i am using the admin account when trying to update the leads.

If it’s a permissions issue it is an operating system permissions and ownerhip issue on files and folders. (so the problem must be solved outside SuiteCRM).

However, as I said before, I am not familiar with Windows permissions so I am not sure that this is the problem nor am I able to help you on this. Sorry.

As suggested in my previous post I would also pursue other potential causes, so, I would also follow @pgr suggestion to test it in a working environment just to exclude (or confirm) that the problem is in your installation.