Undefined in SuiteCRM

Hi Guys

After reading so many posts on this subject i am still none of the wiser. Complete novice but testing out suite crm 7.9.4 on godaddy shared hosting plan with cpanel.

I am getting alot of undefined text and even when i save something i get the dialog box with undefined all the time. I have read alot of posts but as a novice not sure if i understand them. I have used the 1 click install in godaddy for installation so i am guessing this has done this correctly.

When i go to my file directory in cpanel my suitecrm directory is showing 755 for permissions then when i go into the folder various permission levels are shown as per screenshot.

Update cant attach screenshot to this thread, clicking add file but nothing happens.

Can anyone help?

Many thanks guys


  1. There is a bug in the blogging software used by this site. Try your attachment again (as a “reply” to this thread), but don’t click directly on the “Add File” box. SLOWLY move your mouse diagonally away from the SOUTHWEST corner of the “Add file” box. When you see the “No file chosen” tooltip, THAT’S where you click to add your file!

  2. I’m not familiar with godaddy, but does it use something like Softaculous or Fantastico to install software scripts? If so, try another install of SuiteCRM to a different sub-directory and if the problem persists, raise support tickets for this issue with your hosting provider and with Softaculous/Fantastico (or equivalent). Neither will directly support any installed software, but if it IS indeed just a file permissions issue, they need to take a look.

Aside: your SuiteCRM install is 2 releases behind. You might also raise that issue with the script installer. My hosting is with Arvixe and they provide cpanel and Softaculous to install and maintain software. (Softaculous always stays up-to-date on SuiteCRM versions … partly because I remind them whenever they are dragging their heels with a particular SuiteCRM update! :angry: )

Thanks Paul

Yes godaddy uses Installatron as a 1 click installer but i agree its much better to install the later version which i will do now rather than using the installatron as there always slightly behind the times. I simply used this as it was quick an easy to test the software to see if it would suit my needs. In terms of permissions this is my screenshot.

I will try the latest version and see how i get on, thanks buddy :wink:


Hi Guys

Just installed latest version 7.9.7 (Sugar Version 6.5.25 (Build 344). This time i have installed this as per instructions manually rather than using one click service by godaddy. I am on a shared hosting and after the installation which completed successfully i still have the same problem, getting undefined. Please see screenshot attached.

After reading various topics i am convinced its a permission issue somewhere but the instructions are not really tailored for godaddy cpanel. As i am new to this i have checked the default permissions of the suitecrm directory and this is set as 0755. When i go into the directory it shows various permissions which i have attached screenshot.

I did try and change the permission on config_override.php to 0775 rather than its default state of 0664 as i can recall reading this somewhere. But still no joy.

Can anyone help?

Thanks guys

Permissions don’t really mean anything without the ownerships (which user owns the file vs. which user is accessing it, meaning, which user your web server is running under).

Don’t assume you have a permissions problem if you see only one "undefined"s or two. That could be a missing label caused by a recent Issue. If you have permissions issues you would be seeing a large amount of “undefined” in several different places, and probably some other failures.

Your cron jobs could also be messing up your permissions, if they’re running under the wrong user. Did you set them up already? How?

Interesting. I’ve had a similar problem when installing through another automated installer (Softaculous). Resetting permissions etc didn’t seem to make any difference.

I’ve since created a clean install myself rather than using an automated installer and the problem has pretty much gone away. The only place I have noticed it in the fresh install is in the reports module - see screenshot below.

@mat8iou you can try it on the online demo to see if the problem is for everyone, or just in your system:


or if it requires admin access, this one (ironicall,y provided by Softaculous, but it works just fine):


If it’s happening there we should check if it’s a bug.

Thanks for the advice.

I tried the demo (not the Softaculous one) and it works fine.

So there must still be a problem at my end, albeit more minor than before.

I’ve already followed the advice elsewhere about resetting the permissions multiple times. Its odd that the issue is mostly fixed and occurs more irregularly now.

Is there any logging that shows where issues like this are occurring?

If you have your cron jobs configured under a different user than your web server’s user, it will corrupt permissions (repeatedly). Try checking that.

How exactly did you set up your cron jobs? See Admin / Schedulers for the instructions at the bottom (that show your web server user).

Thanks for the feedback.

I went through the info in the second post here and tried it again.

Previously I used option to change permissions in my FTP software, but this time I used SSH instead.

I ran a quick repair afterwards and now it seems to be working fine.