Undefined error on pop up screen

Anybody has this issue? When i add dashlets, there is pop up and undefined items.

1 Like

In most cases “undefined” labels are due to permissions issues.

What Should be permissions to solve this?

Try running the attached script, then run Admin->Repair->Quick Repair and Rebuild.
Then log out. close browser window. Re log in and, if you see the problem press Ctrl-F5

(The attached script sets permissions recursively all along the SuiteCRM folders and files. You should copy the php file contained in the zip and call it via browser).

Additionally you have to make sure that config.php sets the right default permissions.

(I also do it in include/utils.php)


Should i put this php file in root folder of suitecrm? When i call it via browser, it was blank page. No result on browser.

yes. It goes on the root folder of SuiteCRM. There is no screen output so that you can also setup a cron job that runs it frequently.

If you want to see what id does you have to edit the first line from:

$chmod_debug_mode = FALSE;

$chmod_debug_mode = TRUE;

Has it had any effect?

1 Like

Yes, i did it but same result :frowning: Something is wrong :frowning:

My Server OS is RedHat. Is there any settings to do it?

This error is really frustrating and has stopped me using SuiteCRM for years! Can anyone solve this?

Yes, I solve this problem. Please check ,htaccess parameter in root directory of suitecrm… When you edit it, look at the "RewriteBase /yourpath " code to correct path. When i change it with correct one, it solves my problem.


To run the script (centos 7) do the following

Save the script to the suitecrm folder as fixperms.php or what ever you want.
eg: /var/www/html/fixperms.php

from cmd line
run sudo php -f fixperms.php

it will update all the permissions and so far everything is working.

good luck.

My shared server let’s me change the permissions from the cPanel -> File Manager but I am not sure if the ownership is set right. The php script you are talking about doesn’t modify the ownership. How can I look for ownership without SSH? :frowning: :frowning:

Are you using HostGator? I am having a similar problem, can’t install

:ohmy: it worked :woohoo:

Hi, will this work on Windows OS with Xamp and is it dependent on version of CRM or not. How to resolve this in windows OS with Xamp. Thanks in advance.

Thanks :slight_smile:

Where is the script?

Can anyone point me to this script, I am in need of it as well. Please, thank you.

How do I get your script?

Hi, how do I get your script?

This is the solution :grinning: