Unable to get Email Template to save images or source code

Hello all,

Working on getting email templates set up and am running into a few issues. It all started when we wanted to attach an email to the template. With the editor it appears to look fine but when we go in to save the template the images are not saved or show a broken image/link in the corner. We have tried both uploading images directly from the server, from a computer on the network and also inserting a direct url to an image. Nothing seems to work or send properly.

Then we tried simply inserting html into the source code and everything appears in the editor perfect but we go to save and nothing saves except the most recently done thing in the editor. I.e. adding a heading panel/box. Of course again, the incorrect email sends when we test it.

Any ideas? We are on CRM 7.10

Let me know if any further info is needed.


Exactly which 7.10.x is this? 7.10.9?

Was it working well before, and now it broke? Or is this a new installation?

Apologies about the late delay, this is kind of a side project and haven’t had the chance to look back into it until today.

It has never worked as far as I know. There perhaps is a setting I need to turn on via php, apache or suitecrm that could be the issue?


Again, exactly which 7.10.x is this?

You can check you ownerships/permissions on the “upload” and “public” folder, which is where the images go.

You can also paste here your exact URL’s of the images that don’t work, it could be the URL formation that is wrong.


I will check those permissions as I don’t believe I have gotten image saving correctly.

As far as saving email template with raw HTML I did discover that I was able to mostly resolve the issue by removing the and tags along with anything before/after.

However, it stills messes up with the formatting after pasting the hmtl such as changing the font colors and font itself and misaligning the images I understand the font my be an issue with the font family not being available/installed on CRM? However changing the colors and etc may also be the issue.
I am also just pasting the source code into a single 1 content panel. I may try yet splitting up the html and pasting panel by panel.

Another option I thought about was simply finding the html file that the suitecrm builder is saving to and copying the code into that.

I’m not quite sure here what the best option is or if I am doing anything wrong/right to mess up the formatting. Somebody that knows the system more intimately than me may have a good direction to shoot?

EDIT The public folder permissions were absolutely restrictied and I adjusted them. However in the email builder for SuiteCRM it does not open anyhting when I go to insert image and select the browse folder icon. It appears to do nothing. This is an issue locally on the server as well as remotely on any other PC. Ideas?

Version info:

Version 7.10.9
Sugar Version 6.5.25 (Build 344)

Thank you!

I am not very familiar with HTML templating, but here are a few pointers…

  • check site_url and host_name in your config.php, this affects URL formation

  • the HTML for templates is saved in the database, not in a file. I’ve heard a couple of people here in the forums saying they paste HTML directly into the database…

  • when troubleshooting image insertion, there are two separate concerns: 1) does the image get saved correctly in the upload folder? 2) Can it be read correctly (correct URL, sufficient permissions)?

Appreciate the help. I had much more luck finding the TinyMCE editor as that seemed more html copy/paste friendly.

Still have trouble inserting uploaded images, currently we are uploading images to our domain/website then getting the direct url and using that to insert images.

I am able to upload images, documents to the suitecrm but the file browse button doesn’t seem to do anything, I opened up the permissions on the two folders you mentioned earlier and I believe the hierarcahel folders above that are opened with the correct permissions as well.

Another issue I have come across that is related so I’ll just use the same thread here; In regards to email attachments, we have a few templates send an attachment that it pulls from the documents. Everything seems to send fine and on most devices but it seems that in sending the attachments it renames it without the document type handle as such in this instance with a pdf there is no ‘.pdf’ at the end. All pcs/desktops work fine but some mobile applications are unable to open the file without adding the ‘.pdf’ at the end. Is there a way to handle how suitecrm renames attachments? Or perhaps this has something to do with using the smtp server. I’m not really sure which direction to look.

Thank you!

I don’t know how technical you are, but this might help if you want to learn about how these things are stored “under the hood”


Any way - I doubt that SuiteCRM removes extensions from attachments when sending email - if it does, I would say it is a bug. But I suspect some email client is tricking you, showing the name without the extension, like Windows does by default. Try checking with a different email client, or on a different webmail interface, or checking email source.

To trouble shoot the broken images I recommend, in line with what I mentioned above:

  1. First make sure your image is on your server’s disk, where it should be.

  2. Try figuring out if SuiteCRM is generating the correct URL link to grab it. You can paste your URL here so I can assist you with this.

  3. Only after we are sure the link is correct, we look for other possible blockers (permissions, .htaccess, etc.)