Unable to generate PDF from AOR_Reports module

I am using SuitCRM 7.2.2. I made a record using AOR_Reports module. I am unable to generate PDF for it. Data is exporting in csv successfully. PDF is generating successfully on my local system but on live server, it shows blank page. What can be the issue? Please suggest. I have checked Permissions are 0775. Probably, mpdf object is unable to create.

I am facing the same problem. Actually, the problem appears in CentOS release 6.5. The same application in Red Hat Enterprise 6.4. works fine.
By examining the logs I found that the error occurs in modules/AOR_Reports/controller.php, action_downloadPDF().
The blank page was caused by an Out Of memory php error.
I changed $head variable to a simple text e.g. “


” and tried to output this in the generated PDF.
The pdf was generated but then I got the error “Cannot extract the embedded font MPDFAA+DejaVuSansCondensed”.
There seems to be a problem with this font.
However, if I change
$pdf=new mPDF(‘en’,‘A4’,’’,‘DejaVuSansCondensed’);
$pdf=new mPDF(‘en’,‘A4’,’’,‘Arial’);
I still get the same error.
dejavu-sans-fonts is installed in both servers

Could anybody please help in this confusing problem?

Thank you

I had 7.2.2 insatlled and the report pdf worked for all of my reports. I upgraded to 7.3.2 and the follow occurs. This is repeatable.

  1. My report is a lead report with 2 parameters, Assigned User and Status. The default is blank on both.
  2. I select a user and a status of New and Update. I get the expected query results.
  3. I Download PDF and I get a blank pdf page with header and no results.

error_log shows the following:

[06-Nov-2015 00:46:44 UTC] PHP Notice: Undefined index: parameter_id in /home/teamscor/public_html//AOR_Reports/aor_utils.php on line 70
[06-Nov-2015 00:46:44 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/teamscor/public_html/AOR_Reports/aor_utils.php on line 70

Here is what I also found. The Download PDF is always printing the default parameters no matter what the parameters are set to. Since the default was blank and it returned no results, the PDF report will always show no results. It looks like the new parameters aren’t being communicated to the PDF process.

Is this a known bug in 7.3.2? If so, what is the workaround? The problem also existed in 7.3 but with worse results.

We’ll after 2 hours of searching other topics, apparently this is a “feature” through version 7.4.


LOL. What good is this report parameter concept if you can’t export?