unable to add tab and add dashlet

version 7.11.3
Hi, I am trying to add tab and dashlet but only can see spinning wheel. Please let me know how to fix this issue.

Hi , Please follow the thread link below to get the solution


Hi, I already tried everything in this link but nothing helped.

What is your PHP version?

What do you see in your logs at the time of that bug?

And in your browser’s Developer console, any Javascript errors?

PHP version- 7.2.18
attached is the image, I don’t see any error log by clicking on action and add tab.

Thank you!

The logs are files in your server, not options on the UI. Did you go looking for those? What about the developer console, do you know how to get there?

@guptak1 in the top right corner of your SuiteCRM webpage, click on your username, then profile. Next, at the top, click on reset homepage. Then, go back to your home page and add your dashlets. This happened to me before, and this fix worked.

Hey guys,

I have the same problem. I tried to reset the homepage. It did reload the default containers but it didnt help. I still can’t add any other containers cause all I see is a spinning wheel. This is happening to me since version 7.11.13 till 7.11.17 now.

There is a JS error in console. Here it is:

Uncaught SyntaxError: Unexpected identifier
    at eval (<anonymous>)
    at sugar_grp1.js?v=mZGth-0gO9B6Li-CyYisxw:428
    at Object.globalEval (sugar_grp1.js?v=mZGth-0gO9B6Li-CyYisxw:428)
    at Object.success (MySugar.js?v=mZGth-0gO9B6Li-CyYisxw:72)
    at Object.handleTransactionResponse (sugar_grp1_yui.js?v=mZGth-0gO9B6Li-CyYisxw:38)
    at sugar_grp1_yui.js?v=mZGth-0gO9B6Li-CyYisxw:38
(anonymous) @ sugar_grp1.js?v=mZGth-0gO9B6Li-CyYisxw:428
globalEval @ sugar_grp1.js?v=mZGth-0gO9B6Li-CyYisxw:428
success @ MySugar.js?v=mZGth-0gO9B6Li-CyYisxw:72
handleTransactionResponse @ sugar_grp1_yui.js?v=mZGth-0gO9B6Li-CyYisxw:38
(anonymous) @ sugar_grp1_yui.js?v=mZGth-0gO9B6Li-CyYisxw:38

Any suggestions on how to proceed here? I didnt touch any JS files (especially a core files) so its pretty weird.

Admin / repair Dashlets?

Nah not working at all :frowning:

I’d have to be able to reproduce this locally in order to investigate… but I’m afraid I don’t see it happening here…

Well it seems like theres something wrong with a core JS I will try to replace that or work with it when I have a minute. Its not that important at the moment. Thank you for your response though :wink:

1 Like

initially I was using IE browser and had these issues but later on I start using GoogleCrome and issue resolved itself.