Unable to add a dashlet

I was never able to add a dashlet that I wanted in the dashboard. I tried multiple different versions of SuiteCRM but this simple feature has never worked for me. What could be the problem? My current version is 7.9.0.

Any help will be greatly appreciated.

Dashlets are finally working for the very first time for me. I ended up re-doing permissions to the html root folder and all that’s in it with a chmod command.

I think this is something that needs to be added as a requirement when installing SuiteCRM so that people wouldn’t have to deal with permissions later. When I was installing SuiteCRM i passed all of the permissions requirements yet I still didn’t have dashlets working because of the permissions.

Could you write down where to change permissions?

I issued a chmod command for the html folder and all folders that are in it like this:

chmod -R 775 /var/www/html/

and then the same command for each folder that’s in html/ directory.

That fixed the issue.