Two instances, one v7 and one v8, using the same database?

I have a very simple question, at least simple to formulate; perhaps not so simple to answer:

Is it possible to have two instances, one v7 and one v8, using the same database?

I have v7.13.3 and v8.3.0 on the same server, reachable by separate addresses, obviously, with two different databases. I use v7 for regular work and v8 just for testing. Periodically I backup the v7 database and restore it to the v8 instance, just to keep comparing the performance.

To migrate to v8 definitely, it would be good to have the v7 on line, on the same database, just to be able to perform a function that wouldn’t behave correctly on v8.

So, is this possible?

This sounds like a recipe for trouble, I wouldn’t recommend trying it.

The different versions may have differences in the code that affect the way the data is laid out, or interpreted, etc. You would never be sure you’re not messing things up.

Thank you for your advice.

I thought I could try it once that, as I said, I’ve been operating both versions side by side with the v8 database being imported regularly from v7, and seeing no improper behavior.

Once I’m afraid of taking the final jump to the v8, I’ll give it a little more time.

What you’re doing is an interesting experiment… But it is an experiment! If you have it sufficiently well experimented, and feel the risks are covered, then sure, go ahead.

Thank you again.

After your advice I guess I’ll take some time to get acquainted to the idea. I have my data backed up for months back but there could be errors generated by the “experiment” that wouldn’t be noticed until too late.

1 Like

Just to illustrate what I said above, I tried to put v8 on line, and had to give up. Let’s see:

Deleted v8 test installation, made a clean migration, by the book, from v7.13.3 to v8.3.0, choosing keep (and later another try with merge), disabled v7 cron, reset permissions, …

Then tried to import 3 emails just to get a one-line window “undefined”. The log has multiple lines with “unfound relationship”. Did Quick Repair, Rebuild Relationships, Rebuild Emails, to no avail.

Stopped v8 cron, enabled v7 cron. With v7, the email import and everything else works as expected.

So, placed v8 back on test.