Trouble with GET Requests on SuiteCRM8 8.2.4 API: Module ID Empty Error

Hello, I have a problem with get requests on the SuiteCRM8 8.2.4 api, which can be very easy to solve, since it’s the first time I’ve worked on api in my life. You should know that I do all this from python via the Requests library.

To log in and obtain the access token, the only method that worked on our API (although I’m not sure why) was to use “/legacy/Api/access_token” instead of “/Api/access_token” as mentioned in the documentation. The latter option leads to a “page not found” error.

No worries, I managed to obtain an access token successfully. I even retrieved the list of modules using: “legacy/Api/V8/meta/modules”. However, when attempting to access the complete modules using our accounts via “legacy/Api/V8/module/Accounts”, I encountered the following error: “Module id is empty when trying to get Users”.

Has anyone encountered and resolved a similar issue?
Here is my code, maybe it’s just a mistake:
headers = {
‘Authorization’: f’Bearer {access_token}',

response = requests.get(‘{myURL}/legacy/Api/V8/module/Accounts’, headers=headers)"

Thank you for your assistance!