Trouble with blank "Use Mail Account" dropdown when setting up Marketing Email Campaign in 7.2.2


I’m new to the forums and first want to say how much I appreciate the work that so many people have put into developing and supporting this software.

I’m using version 7.2.2 installed with the GoDaddy Installatron. My outbound emails are working perfectly fine. I haven’t had much desire to use Suite for inbound email yet so I hadn’t barked up that tree until today… but more on that in a few.

I tried setting up a test Marketing Email campaign and found that the dropdown menu labelled “Use Mail Account” had no options other than “-none-”. I triple checked that I was, in fact, able to still send outbound email using the system account and my user account. Both of those work fine. I went ahead and left the dropdown on “none” and tried the campaign, but no emails were sent out. So I did some Googling and most of what I saw (other than configuring outbound emails, which I had already confirmed to be working) pointed towards setting up an inbound email account by going into the Email module and clicking the settings button, then adding a new inbound email account. So I tried that. I found that when I entered in my Gmail details and clicked Test Settings or ANY of the select buttons (to choose monitored folders, trash folder, and sent folder), Suite gets stuck on a “Loading” window and never proceeds any further.

So now my primary issue is that I am unsure what I need to do to get my email blasts to actually send an email out - I still don’t have any email accounts in the “Use Mail Account” dropdown. My secondary issue, that may or may not be related, is that I can’t get past the “Loading” screen when adding inbound email accounts. I really want the email blasts to work. If it just so happens that by fixing the email blast issue, the inbound email is also resolved, all the better.

Any idea what I should try?

I’m still having issues here, but think I may be making progress. I tried setting up a bounce email account and noticed that again I was getting stuck when trying to test or save the account details. It’s also a Gmail account, like the account I have been trying to use for the outbound email.

In doing a bit more reading, I’ve seen some older posts by Sugar users that say there are some issues with Sugar using a Gmail account on GoDaddy hosting, but haven’t seen if there is a good workaround or resolution. Is that a likely culprit for my issue? And if so, is there a way to fix it?

Does anyone have any pointers? Am I missing something obvious?