Tried installing Suite8 beta 2 and get legacy GUI with no css

I have followed the installation instructions at

for installing the beta-2 of version 8 of SuiteCRM

Note, the instructions did not include the requirement to install Composer, but it is required so I did that as well.

When all was done, I pointed my browser to the installation and what was displayed (after login) was the SuiteCRM home page (I think) but with no css so it was not useful.

I have re-checked the permissions and all is as instructed.

I did notice that at the end of the installation, after running
./bin/console suitecrm:app:install
I had
Step 1: Config Creation Complete
Starting SuiteCRM CLi Installation
SuiteCRM CLi Install Complete
Step 2: Legacy Installation Complete

I installed it on a fresh install of Debian 10

I did NOT set the webserver root directory to the Suite8 subdirectory; This system is usede on my LAN only as a development system and I want to use this system for development of SuiteCRM and other projects (NOT yet installed) so I pointed the browser to the IPAddress/suite_subdirectory

I also tried pointing the browser to IPAddress/suite_subdirectory/public but I got an error notice for that saying to run ng build from the terminal but when I did that (as root), I got the “ng commoand is not found” response and sure enough, when I did a whereis ng, there was nothing.

Has anyone experienced this and if so, what was the resolution?

I did get a bit further by searching for my URL (IP Address) in the Suite directory and found it defined in the public/legacy/config.php directory.

So I set the browser to
and I did get a (basic) login screen presented
After entering the UserName and Password, I was sent to the hom page of the SUuiteCRM installation (I think) but there was no css so it was not usable.

I have re-set all file permissions as specified.

Any ideas as to what is wrong?

I’m also able to log in - but without CSS.

Did you ever find out what the problem was ?

I do get a ‘call to member function getDebug() on null’ error on line 124 of AddNewConfigEntriesHandler.php when running the post upgrade command.


I gave up on v8 and am working with v7 until such time as I think v8 is mature enough to move a production system to

So no, I never resolved this

ok thanks

think i’ll need to do the same, feeling a little left behind :confused:

I felt the same way until I read some of the reviews on v8. Happy to stay with v7 for now. There is a LOT of evolution required before I’d want to put v8 into production. It has promise, but I don’t want to expose my clients to promise.