Time out error during upgrade

I tried to upgrade this evening from Version 7.10.1 to 7.10.4 using the upgrade wizard. At first I had a timeout error during the system check. I increased:

max_execution_time = 1000

Now I get a timeout error while trying to upload the upgrade file. The upgrade file is under 16M. I increased the upload_max_filesize to 256M. Still no luck . I get a 524 time out error every time. In the wizard it shows all the previous upgrades . Prior to this we have upgraded 12 times. Not sure why I am having issues.

The sugarcrm_05_01_18.log reads Tue May 1 00:17:17 2018 [9256][1][FATAL] ERROR: There was an error during your upload, please contact an administrator for help.

Try checking your permissions on the “upload” directory, and to clear up left-overs from previous failed upgrades you can rename the “upload/upgrades” directory to something else. It will get recreated.

Then you can delete the old directory when you are convinced it won’t be needed.

Thanks. I just tried that. I rename the “upload/upgrades” to “upload/upgrades_old”. In the upgrade wizard I tried to upload SuiteCRM-Upgrade-7.10-to-7.10.4.zip and got a Time Out error. I checked and it did create a new directory “upload/upgrades” and the permissions are set to 755.

You should check if your changes to php.ini are really taking effect, sometimes this is not easy. Have you restarted Apache?

There is more than one php.ini in your system, so go in Admin / Diagnostics and get your phpinfo from there. Check your php.ini path, and check the max_execution_time that is shown in phpinfo, see if it matches what you configured.

I tried everything on my shared server, I mean a whole day of edits and nothing worked, eventually I moved everything to my local server and upgraded there, then moved everything back again. works like a charm now! Plus, it took relatively little time!