The zip file is missing a manifest.php file.Can not proceed

Hi guys,
I installed freepbx and I try to configure it with my suitecrm version 7.11.2.
He give me a plugin but when I install it he says “The zip file is missing a manifest.php file.Can not proceed” and when I leave the files at the root of the zip he says “invalid package”.
Can you help me to solve the installation.

Where are you trying to load it? My guess is that you are trying at the “upgrade wizard”, when you should be trying in the “module loader”.

Anyway the plugin developers should provide the necessary instructions…

1 Like

Thanks for reply sir;
i load it in module loader.
The developper rediirect me to this page for instruction
i do what he say but the plugin in attachement file do not load.

When you unzip this Zip , manifest.php should be in opened folder , not inside any other folder.
Many developers make zip of folder , which is wrong.
Zip must be made of folders file not folder.


Don’t put manifest.php inside folder. keep it outside of folder and select the all files and then compress it to Zip. So that when someone extract that file then he should get all files open and NOT A SINGLE FOLDER CONTAINING manifest.php.

I have rezipped the upgrade files as described here, but still get the same error message. I have not been able to upgrade my SuiteCRM installation successfully.
Here are a few points to note:

  • I am trying upgrading from 7.11.20
  • When I try upgrading to version 8+, the file uploads, but the upgrade simply get stuck
  • When I try upgrading to 7.12+, I receive the manifest error message
    Am I missing something?