The product image is not showing

Hi evreyone,

I have tried upload the image in product but it is not showing. I have uploaded the image in attachment. Anyone got this issue and fixed it can you help me. :frowning:

P/S: I already setup permission 775 for some folders which is requirement.

Thanks & Best Regards,

Yes, It was also met with version 7.10.2, and I’m going to find out.

Here you are – thank to @rodsales i found that “had an .htaccess file in the upload folder itself too.” delete it or rename over… all return to working ! Take a look Solution here!

I discovered that removing the .htaccess in the Upload folder does not solve this problem, when you upload a new image. Should follow this correct: at Config.php: full url

  'site_url' => '',
1 Like


Was this ever figured out? I am having the same problem.

Any suggestions I have the same problem in SuiteCRM Version 7.11.18
Permissions are set up correctly

Hey @smek

It may be worth creating a new thread, as this is a bit of an older one

However, some things that might be worth checking:

Which PHP version are you on?
There is an existing Bug that may be related:

If you hover over the image, or Right Click->“Copy Image Location” on the Image, to grab the Image’s URL
What URL do you get?

It should contain an ID in the format of: “xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_photo”

Can you navigate to your CRM’s Upload Folder, and check that a file exists in that folder, that has a name that matches the ID that you can see from the record?
If it exists, this file should have read permissions, does it?

Hi, @John
May be is it problem with ‘.htaccess’ and ‘upload/.htaccess’ ?
I saw the problem on my system. When I changed in file ‘.htaccess’ the line:

RedirectMatch 403 (?i)/+upload


RedirectMatch 403 (?i)/+upload(?!.*(\.png|\.jpg|\.gif|\.pdf))

and I removed file ‘upload/.htaccess’ all began to work.
But I don’t sure in this decision.


Hey @p.konetskiy,


Bad images could also be .htaccess issues, It would also be something worth checking out!