Text formatting in the body of incoming email


I’m new to SuiteCRM and having some trouble with text formatting in the body of incoming email. This is both for personal and group mail accounts.

If there is any formatting or any attachments in the incoming mail, then “junk characters” showing up in the body.

See below examples:

The problem gets bigger if any swedish characters (åäö) exists in incoming email. äåö in plain text emails shows up just fine but if the above happens, then åäö also turns in to “junk characters” and the email is totally unreadable.

  • Version: Tested on both SuiteCRM 7.10.20 LTS and SuiteCRM 7.11.8 (both clean installations, one with Swedish Language pack)
  • Server: Local on my Mac (PHP 7.1) and on external host with Linux (PHP 7.2). Apache on both.
  • Charset in SuiteCRM settings: I’ve tested both UTF-8 and ISO 8859-1 (Latin 1)
  • Database: Mysql (UTF-8)
  • Inbound mail accounts: Tried both gmail and one other email service with the same results.

Hi, welcome to the Community.

Thanks for the nice screenshots and explanations, you’ve made the Issue very clear.

I wonder if there’s already an open Issue for this on GitHub, have you searched there?


If you don’t find the same issue there, I ask that you open a new issue there, this seems good enough to start a bug report and hopefully somebody with developer skills can pick it up… thanks

Thank you. I have now opened a issue here: https://github.com/salesagility/SuiteCRM/issues/7801

Nice, thanks.

Maybe you can edit your Issue and make the screenshots appear inline? It is not hard to do and it makes things more straightforward for people visiting that issue. Thanks for reporting!

Thanks for the tip. It was easy :slight_smile:

1 Like