Is there a glitch when creating a template?

When I click on the ‘Load Sample:’ dropdown list, there are no names displayed. According to the user documentation there are seven sample templates supplied. From what I can see there are seven items in the list but their names aren’t shown. This happens on the version I’ve got installed on my laptop (Windows 7, SuiteCRM v7.9.5) and on the demo version at (https://suitecrm.com/demo, also v7.9.5).

Also, is there a glitch when editing a template?

When I edit a template (Windows 7 and Demo version), the wysiwig edit panel only contains HTML code (not even with line breaks for each new statement) and the HTML editor contains the same (I would expect it to be a line editor).

Also, on the demo version, although a list of templates created is shown, when one clicks on a template to view it the panel doesn’t show. It just shows an empty dashboard.


Email Templates, PDF Templates, Project Templates? Which ones do you mean?

It’s better if you phrase things as “steps to reproduce”

  1. go into X module
  2. Press y button

Apologies for not posting sufficient detail about recreating the glitches.

The glitches occur on PDF Templates and Email Templates. I haven’t tried project Templates.

To recreate the problem:

  1. Go to PDF templates
  2. Then Create PDF Template
  3. If you click on the ‘Load sample’ list box you’ll see that it consists of a list of items but the names don’t show
    This is the first problem
  4. If you select one of the empty items, the form will be populated from that item
    The body is in wysiwig format
  5. If you click the HTML icon in the top LH corner of the wysiwig panel the HTML is shown in line editor format
  6. Provide a name and click Save to save the template
  7. Select edit to edit the newly created template
    The body in on linger in wysiwig format but just unformatted HTML
    This is the second problem
  8. Click the HTML icon
    The HTML panel shows unformatted HTLM, not Line Editor format
    This is the third problem
  9. Exit this by save or cancel
  10. Click ‘View PDF Templates’
    This shows a list of the templates
  11. Click the template just created
    An empty dashboard is displayed - screenshot attached
    This is the fourth problem

The same is true when editing Email templates

Problems 1, 2 and 3 occur in my Windows 7 laptop installation.
Problems 1, 2, 3, and 4 occur on Demo SuiteCRM

The reason I checked the demo version is to determine whether or not the problem occurs in an environment other than Windows 7.

1 Like

I was able to successfully parse your " in on linger in" as meaning “is no longer in”! Amazing! That was another senior moment right there, wasn’t it? :slight_smile:

Now more seriously, that’s a great report, thanks! The first problem is clearly a bug and I have reported it:


For the other issues, can you try experimenting with the settings in your user profile. At the bottom you will find “Email settings” and there are some things there about your Email editor, maybe you can do what you want changing something there?

1 Like

I’m impressed with your parsing though I put the problem down to dyslexic fingers rather than a senior moment.

I feel chuffed that I’ve found a new bug!

I’ve tried all the combinations of Email Client and Editor but nothing has affected the appearance of the wysiwig editor no the HTML editor.

I don’t know any solutions for the HTML editing, but now that you’ve visited Github you might search it for related issues. Sometimes you find somebody else already identified a problem similar to yours, and sometimes there are even suggested fixes. Good luck.

I couldn’t find any fixes but I did discover someone with the same problem (https://suitecrm.com/forum/suitecrm-7-0-discussion/15336-wysiwyg-editor).

It looks like the same problem here:

I’ve experienced this error as well (the image placed in the wysiwyg panel gets lost after saving).

All in all there’s quite a lot wrong with the templates.