System Settings not saving (was working fine previsouly)

I wanted to change “Listview items per page” value but when I save, it doesn’t actually save it. I go back in, and the previous value is displayed (I’ve tried other settings and the same thing occurs). Did some digging and the permissions on config.php & config_override.php were fine (775 - plus I reset them for good measure). I can manually change the files, but config_override.php gets reset all the time by “something”. I even renamed the config_override.php file and it was recreated by suitecrm. Tried “Quick Repair and Rebuild” and “Rebuild Config File” without luck. There’s nothing in apache or sugarcrm logs. How does config_override.php get regenerated? I’ve got a feeling it has something to do with that. Thanks for any help.


Have you checked the ownership of files once they are created/Edited by the system?


You could also try (although you seem to having done these things):

. reset manually all file permissions (775/755 depending on files/folders. There are lots of forum topis on this, including a script I posted to do it programatically from php, which could also be used regularly with a cron job)
. reset manually group/user owner
. check and update if necessary the config.php values of default permissions (file_mode, dir_mode, user, group)
. same for config_override.php
. edit also include/utils.php and set the correct permissions and correct a bug found in that file (there are two mentions of default_permissions in the file. search for “default_permissions” and replace the related code in both with what you set in config.php) (the bug consists in that, in one of the mentions “user” is referred to as “chown”, “group” is referred top as “chgroup” and the values are in octal rather than in decimal.)

Then, once done do a quick repair and rebuild and try again

  • I have the correct user/group on all the files (in my case www-data & www-data). I’ve already tried manually resetting user/group and perms on all files without luck.

  • dir_mode => 1528, file_mode => 432, user => ‘’, group => ‘’ - Default values that have never been changed and have been working up until yesterday (www-data is properly associated on new files created by suitecrm).

  • default permissions not over-ridden in config_override.php

  • Bugs fixed in include/utils.php

  • Repair and rebuild performed

Unfortunately issue is still present. I still think it has to do with config_override.php. Remember, I renamed that file and it regenerated itself. How it does that and where it retrieves the values to populate the file, I don’t know. For example, the setting “list_max_entries_per_page”, is set to 20 in config.php & include/utils.php (the defaults). Now it’s present in config_override.php but with 2000. If I manually remove the line from config_override.php and visit “System Settings”, that value is immediately added back to the file without me doing anything. It seems like that value is somewhere (db, file???) and always takes precedence no matter what I do.

Forgot to mention that even if I manually change the value of “list_max_entries_per_page” to 20 in config_override.php, it does not take effect unless I would do a quick repair. That will reset “list_max_entries_per_page” to 2000 in config_override.php.

Ok things are getting weird. Now it’s back to 20. I’m starting to think that maybe it has to do with caching of some kind…

Alright, seems like another member of the IT staff had done some tweaks to zend caching without notifiying me and that was the culprit. Sorry for wasting everybody’s time.

Glad to hear that you managed to solve the issue!