Symphony error on fresh install of V8

I’ve installed v8 as per the installation guide but when it get to running the installer I’m getting a symphony error -

Fatal error : Uncaught Symfony\Component\DependencyInjection\Exception\RuntimeException: Cannot autowire service “App\Install\Command\InstallExtensionAssets”: argument “$name” of method “__construct()” is type-hinted “string”, you should configure its value explicitly. in /var/www/crm/vendor/symfony/dependency-injection/Compiler/DefinitionErrorExceptionPass.php:54 Stack trace: #0 /var/www/crm/vendor/symfony/dependency-injection/Compiler/AbstractRecursivePass.php(82): Symfony\Component\DependencyInjection\Compiler\DefinitionErrorExceptionPass->processValue() #1 /var/www/crm/vendor/symfony/dependency-injection/Compiler/DefinitionErrorExceptionPass.php(32): Symfony\Component\DependencyInjection\Compiler\AbstractRecursivePass->processValue() #2 /var/www/crm/vendor/symfony/dependency-injection/Compiler/AbstractRecursivePass.php(47): Symfony\Component\DependencyInjection\Compiler\DefinitionErrorExceptionPass->processValue() #3 /var/www/crm/vendor/symfony/dependency-injection/Compiler/Compiler.php(82): Symfony\Component\DependencyInjection\Compiler\AbstractRecursivePass->process() #4 /var/www/crm/vendor/symfony/dependency-injection/ContainerBuilder.php(757): Symfony\Component\DependencyInjection\Compiler\Compiler->compile() #5 /var/www/crm/vendor/symfony/http-kernel/Kernel.php(541): Symfony\Component\DependencyInjection\ContainerBuilder->compile() #6 /var/www/crm/core/backend/Kernel.php(124): Symfony\Component\HttpKernel\Kernel->initializeContainer() #7 /var/www/crm/public/index.php(34): App\Kernel->getLegacyRoute() #8 {main} thrown in /var/www/crm/vendor/symfony/dependency-injection/Compiler/DefinitionErrorExceptionPass.php on line 54

Does anyone have any suggestions?

I’m running php8.1 with all of the required modules except ldap (which is listed as optional), and mariadb 10.3.32 on Ubuntu 20.04. I’m wanting to use Nginx as my webserver but I’ve also tried using Apache with the same result.

I’m having exactly the same problem, as far as I can tell. No thoughts from the maintainers?

I thought that the issue might be that the Symfony framework wasn’t properly installed. I followed instructions here:, particularly regarding installation of the Composer system for PHP package management. But same error after all of that.

I tried uninstalling PHP8.1 and all related packages and using PHP8.0. For the first time, the initial page with the license is showing up. This appears to be the issue. :roll_eyes: Given that PHP8.1 is the latest version, I’m surprised that this problem exists.

PHP 8.1 is not supported yet.

The correct place to check is here:

I’m not very up to date on PHP, can you say why a minor version change would be incompatible? 8.1 is, after all, the most recent and logical version to install.

Because of this:

… which involves a lot of work in a code-base that includes tons of legacy code and has maybe over 1 million lines of code…

Basically, don’t think of PHP decimals (8.x) as minor versions. Only the changes below that (say, 8.0x) are minor.

The most logical version to install is “the newest in the Compatibility Matrix”, not simply “the most recent”.

@AaronH @Newintellectual @pgr I am getting the same error but I am using PHP 8.0… It would be awesome if you could give me a hand. My thread is here.