SuiteCrm8 installation with bitnami lampstack virtual machine

Hi All,

I have tried to install suitecrm8 within the bitnami-lampstack-8.1.2-0-linux-debian-10-x86_64-nami.ova virtual machine, under Oracle Virtual box, but I it is impossible.
After unzipping the suitcrm8 file and make other changes regarding file access permission I get to a point that when I use the virtual machine ip address in the browser (https// instead of getting the suitecrm installation page I get a 403 Error “Forbidden You don’t have permission to access this resource.” page.
I tried opening an “hello world” php file in the same directory and no problem.
Adding the suitecrm public folder I get a blank page.
I asked to the bitnami experts and after a couple of tries/configuration check it seems that there is some missing extension in Apache/PHP that is making the app to fail. That’ s why I am now asking here.

Does anybody tried installating suitcrm8 within bitnami VM?

Thanks for letting me know

(some screenshots)

Am I the only one trying the Suitecrm 8 installation within bitnami lampstack?


It seems nobody tried before me.

@mariofucile I encountered the same “Forbidden…” problem so you are not alone. I am attempting to install on FreeBSD v13 with PHP 8.0.15, Apache 2.4.52 and MariaDb 10.5.13, and using the recommended vhost definition in the installation instructions.

Since our hosting systems are different, I created a new topic with my own hosting information.

Did you try these permissions listed in the install docs?

find . -type d -not -perm 2755 -exec chmod 2755 {} ;
find . -type f -not -perm 0644 -exec chmod 0644 {} ;
find . ! -user www-data -exec chown www-data:www-data {} ;
chmod +x bin/console

Section 2.3 on this page - Downloading & Installing :: SuiteCRM Documentation

Thanks for your reply, so I am no alone…it would very useful to get the installation work.

Thanks for replying.

I will try these commands, just a basic question, are they ment to be executed from the root folder?

Yes, execute them from within the root of your SuiteCRM directory. Note you may require root privileges or use sudo with all commands (e.g. “$ sudo find…”).

Also note you must replace “www-data” in the commands with the user and user group the apache web server is running as (“user:group”). You can use “ps faux | grep httpd” to see the user httpd is running as, and then use appropriate commands to find the user group. Likely the group name is the same as the user name, but I am not familar with Bitnami and it was not clear from a quick browse of Bitnami LAMP documentation just now. E.g. Understand the default Apache configuration

P.S. Fwiw, I successfully installed the latest SuiteCRM v7 release without issue. I suspect there is some subtle changes in how v8 is served that is tripping us up.

Hi Dale,

Thanks a lot for your reply.

At first I tried the “ps …” command" and if I do not get wrong the user and group are the same → daemon

I tried the above commands (in the above ones a “” is missing at the end) replacing “www-data” with daemon. I did it in the /opt/bitnami/myapp/suitecrm directory using in some case the sudo option. No errors.

Now using the address https// or https// or https// I get always the “403” Forbidden error. Before these commands I got the blank page.

From the below screenshot can you confirm I used the right user:group (daemon:daemon)?


It seems right, you can confirm the group for user daemon by:

$ groups daemon

The “Forbidden” error trying to access could mean Apache does not have read permission to the default index.html file (i.e. “Hello, World!”). but it might also mean Apache is not permitted to serve the index.html file according to the configuration of httpd.conf (or other included configuration file).

Did you create a vhost as described in the SuiteCRM V8 installation instructions, or modify httpd.conf in anyway?

Examine the Apache error log file for more information. On my server the error log file is /var/log/httpd-error.log, but on your server the path and possibly name also will be different.

First access for what should be the default “Hello, World!” page, then examine the error log file to see what error prevented the page from rendering. E.g. “$ tail /var/log/httpd-error.log” (using the correct path and name for your server).

Hi Dale,

thanks for your informations.
From bitnami docs (Debug Apache errors) I found out that the Apache error log file is located at /opt/bitnami/apache2/logs/error_log .

So I tried to access the suitecrm folder with the following address: https//
I got the forbidden error.

I looked into the error_log file and at the end found the following error:

[Wed Mar 02 18:57:47.967915 2022] [core:crit] [pid 993:tid 139795875456768] (13)Permission denied: [client] AH00529: /opt/bitnami/myapp/suitecrm/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/opt/bitnami/myapp/suitecrm/’ is executable

I checked and found out the “suitecrm” directory with permissions 644, so changed to 755.
Then I checked .htaccess file permission, found 644, so no change.
I restarted apache.
Tried the same address (https//, same result “Forbidden”.

What do you think?


Thanks for letting me know.

Hi @mariofucile, I regret I am not familiar enough with Bitnami stack and configuration to guide you further. However it might be helpful to get the basic “Hello, World!” default Apache page working first, which should be a simpler problem to solve. Once you have the default page working, then move on to SuiteCRM.

SuiteCRM is so much straight-forward to install in plain Ubuntu than it is on Bitnami… I don’t know of any valid reason to go with Bitnami in the case of SuiteCRM (although I respect Bitnami and appreciate their work and their competence).

And more so when you’re looking to upgrade the stack somewhere in the future.

1 Like

Hi Dale,
sorry for my delay, my linux stopped working and had to reset all.

Thanks anyway for your help.

Hi pgr,
sorry for my delay, my linux stopped working and had to reset all.

I am trying installing SuiteCRM v8 using bitnami lampstack to use it in a virtual machine.
What do you suggest as alternative?


Plain Ubuntu server in a VM is what I use.

apt install lamp-server^

apt install zip unzip iotop htop php-mbstring php7.3-mbstring php-gettext php7.3-xml php7.3-zip php7.3-imap php7.3-gd php7.3-curl php7.3-intl php7.3-mysql php-gd phpmyadmin php-xdebug

Remove XDebug if it’s not a development machine. Adapt package names to your PHP version.

Hi pgr,

Thanks for your reply with instructions included and sorry for my delay.

I just figured out to install Ubuntu Server 18.04 in Oracle VM (I got error with 20.04, do not know why), checked options LAMP plus Minimal during the installation process. At the end added some missing component present in your 2nd install line. At the end found out php version is 7.2

SuiteCRM v. 8.x minimum php version is 7.3…any suggestion for a quick and secure php upgrade?


I normally just Google for a very specific step-by-step tutorial like

“upgrade php 7.2 to 7.4 in Ubuntu 18.04”

Yes you are right…sorry for asking.