SuiteCRM - Workflow module limits?

I created a workflow that invovlve 9 tasks.
Basically the workflow is as such
Projects > Create 9 project tasks

However when i run the workflow it only generate 6/9 of the project tasks.

Thereafter, i deleted some other workflow and rerun this workflow and suprisingly it created 9/9 of the project tasks.

It seems to me that there is a hidden limitation to the code that it can be written.
If it is true, is there any place that i can increase the limitation ; if it is not, can anyone advise what went wrong here?

I need to increase the limitation as i am creating quite a number of workflow.

Even if it had such a limit, which I doubt, it should be per workflow, and shouldn’t be affected by changing a different workflow!

So either this is a bug, or something wrong with your system.

If you can get it back to a situation where it’s failing, and it’s reproducible, you should check your logs for any errors during failure:


Thanks pgr for the reply.
I definitely will look into the error log to see what is going on.

I have attach a few screen snaps for easier visualizations.
Kindly advise opinions/diagnosis based on my screen snaps if any.

  1. All my workflow (13 of them)
  2. Workflow with 8 tasks
  3. when ran it only generate 2 out of 8 tasks for me
  4. I have to delete some of my other work flow then rerun the process then it will generate more tasks from the workflow.
  5. however during the process it did produce this error(refer to errors.jpg) but i just ignore it.(could it be the reason?)

The first thing you should do is to turn off display_errors in your php.ini.

You shouldn’t be seeing errors on screen, you should just track them in the logs. And this can be a problem, but some errors that are harmless in the logs, can break functionality by being displayed on screen.

That error about “exceeded 1000 limit in Accounts query”, why is that happening? What do you have in your workflows that could be doing such a query?

I tried to resolve by adding the module into the array and increase the limit and the error are gone. The workflow problem is solved too.

Wondering is there any setback by doing so?

It’s probably just a performance precaution…

Is you database huge? Should it be?

Try the first query in this post, it’s really insightful:

1 Like