SuiteCRM upgrade from 7.13.1 to 7.14

Hello All,
I am upgrading the instance from 7.13.1 to 7.14, after uploading the patch upgrade from the upgrade wizard it shows a 500 Internal server error. Attached is the screenshot for the reference.
.Made changes in the php.ini file (max_input_time, upload_max_size).

.PHP version - 8.0
.IIS - 10
.Sql server -2019

Pls, need your suggestion to fix this.

Thanks in Advance.

That’s just a timeout, all you need to do is increase a setting in your php.ini and restart your web server.

If you had simply typed the text of your error into Google, you would have found this out .

I believe the setting is called max_execution_time or something similar

Thanks @pgr for the quick response,
I have increased the
max_execution_time =300000
max_input_time = 12000
and restarted the browser too.

Modified the activity timeout to 3000 and requesttimeout=10000 in application-host for FAstCgi
Kindly let me know if any parameters need to be corrected.


In Admin / Diagnostics / phpinfo you can see the effective values of those settings. Check there to ensure you have changed them in the correct php.ini (there can be more than one), and if they have taken effect (did you restart the web server?)

Hai @pgr,
Yes, the changes made are reflected in the proper php.ini file, and after the changes I have restarted the web server. Attached is the file for reference.


So, are you still getting the same error? After how many minutes?

You can try clearing the whole directory upload/upgrades/temp before retrying, failed upgrades sometimes leave a lot of trash there.

Hai @pgr ,
Yes, I have tried more than three times, every time I do I clear the cache/upgrades/temp/ and upload/upgrades/patch/, and the issue remains the same. Please suggest to me if anything to be made.
No fatal errors in php error logs, suitecrm logs.


I asked how many minutes before your error occurs…

If it’s not taking at least 6m (3600 seconds) then your problem is mis-reported, it has to be something else

it is taking at least 1 minute to load the error.

I don’t think this is in any way related to SuiteCRM, you’re probably better off Googling for FastCGI issues with that error text.

ok, @pgr I will check for the FastCGI-related ones.

Please confirm me I have PHP 8.0 for suitecrm7.13, if I upgrade to 7.14 It will not load the instance on the 8.0php version as per the compatibility matrix it has to be 8.1 or 8.2.
How can we load the instance after upgrading?


I advise:

  • full backup
  • run the upgrade using PHP 8.0
  • as soon as it ends with success, change PHP to 8.2
  • run a QR&R and use SuiteCRM normally

Thanks, @pgr
I will try again

Hai @pgr,
Happy to say that SuiteCRM has been upgraded to 7.14 after modifying the activity timeout in the IIS server and works fine.
.But I have a custom code in the .tpl file (custom/themes/TechBlue/_headerModule.tpl) file where the PHP code is embedded. Now when I do repair and rebuild it shows a fatal syntax error:
unknown tag {include_path=‘path_to_file’} and I came to know this has been deprecated after Smarty 3.0.Now we are using smarty v4.3.1.
Pls, help to resolve this issue.


Install the latest version of that theme, it’s probably fixed already. If not, then contact the developers of the theme.