Suitecrm showing HTTP ERROR 500

My suiteCRM jus stopped working. the error below.

This page isn’t working is currently unable to handle this request.

When i checked error log. this is what i found below
[04-Aug-2021 13:10:02 UTC] PHP Fatal error: Uncaught Exception: cron.php is CLI only. in /home/public_html/suiteCRM2/include/utils.php:1898
Stack trace:
#0 /home/public_html/suiteCRM2/cron.php(52): sugar_die(‘cron.php is CLI…’)
#1 {main}
thrown in /home/public_html/suiteCRM2/include/utils.php on line 1898

Please Help! not sure what is happening. Php version is PHP 8.0 . at this moment am not able to access suitecrm to note the version.

May be you can try to switch php version to 7.4 , this may quickly resolve your issue, as I per I know , PHP8.0 not supported yet.

Thank you Ashish. i have done so but same error persist. i have also noted the [ PHP-FPM ] is disabled. Could this be the issue?

I enabled PHP-FPM and it has worked. thank you very much.

The error is too generic and does not tell you exact problem. The first thing you need to know about the http error 500 the page isn’t working is that the error can only be resolved by fixes to the Web server software. It is not a client-side problem meaning that the problem is not with your browser, your computer, or your internet connection. The error is too generic and does not tell you exact problem. When you hit an internal server error it usually means some parts of your web server is not configured correctly or the application is trying to do something and the server is failing to carry out the request due to a conflict or restriction. Please check the error logs on your server for a more specific error message, which may give a clue to why this is happening on your website/server. These errors are often caused by plugin or theme function conflicts, so if you have access to your Dashboard, try deactivating all plugins. It is up to the administrators of the Web server site to locate and analyse the logs which should give further information about the error. However, there are often ways to quickly get around the problem:

  • Reload or Refresh the Webpage.
  • Check you server permission.
  • Corrupt Plugins.
  • .htaccess file may be corrupt.
  • Exceeded PHP memory limit.
  • Increase the memory setting in the wp-config.php file.
  • Clear your browser cookies and cache