Suitecrm Sending Email on Specific date

Appreciate your support that i have a custom module for ex called ( Product and Service ) that contain all services that customer purchased from us - That module contain field called ( Expiration date ) i wont to create a work flow to send a notification email to assigned user before 30 Days from Expiration date .

Ex : Expiration date will be 25th Sep 2019

Want the assigned user to receive an email on 25th Aug 2019

Hi, welcome.

Which SuiteCRM version are you using?

There is a module called “Contracts” which already has this kind of feature (with “Renewal” dates), have you tried it?

For the Workflow, what have you tried, and which specific problem are you running into, so I can try to help?

Hi , Welcome .

Am using Version 7.10.7 - Sugar Version 6.5.25 (Build 344).

I Created a custom module called Services and Products to define each service with Expiration Date as 1st Screen Shoot

The Work flow as the 2nd Screen Shoot

My Problem that i didnt get any email form the mentioned work flow

Please tell us also the other properties of the Workflow (the ones on the top - “on save”, etc)

Sorry for Tardy Response .

Here here the properties for workflow

WorkFlow Module: Service & Products
Run : Only In The Scheduler
Run On: All Records
Status: Active

What about “Repeated Runs”? Is it checked?

Sending email is sometimes problematic. I suggest that first, you try your email with a simpler action - for example, setting a field to a certain value, just to make sure that the Workflow runs, and that your condition works. Once that is working, you can worry about sending email.

The condition could be having some problems with the date format, that happens…

Repeated Runs already checked yes .

Work flow working normally if (Run : Only In Save) but once changes to scheduler . noting happens ?

Well, these are technically two very different forms of execution.

Do you have your Scheduler jobs well set up? The instructions are in Admin / Schedulers, at the bottom of the table.

I Already Create a Scheduler as screen shoot , and still having the same issue

That says

last ran successfully: Never

so they’re not working. Did you create the entry in crontab as per the instructions?

I Dont now how to create the entry in crontab actullay

How can i create it ?

What is it about this that you’re having trouble with? Don’t you have access to a console on your system? If that is the case, sometimes setting cron jobs is possible through CPanel.

Its working right now . after following the crontab instructions.

Thank you so much for your efforts

1 Like

Sorry Again.

The Scheduler and work flow working normally but i need to to configure the work flow to send an email before 30 days from expiration date . how can i do that ?


When dealing with dates in Workflows, don’t use “equal”, that would only match if the Workflow happened to run at the exact time (not just date) that the Product happened to be 1 month from expiring.

Always use Greater than or Lesser than. I tend to get the two confused so I just try one, if it doesn’t work, try the other… :wink: