SuiteCRM migration to shared hosting


I have a problem for which I would really appreciate your help.

I have a SuiteCRM 7.0.1 installation (previously successfully upgraded from a Sugar CE 6.5.14) on a virtual Ubuntu 12.04 machine.

Today I tried to migrate this instance to an other server (again Ubuntu 12.04 but with Plesk 11.5). I copied the files through ftp, created the database and database user with the same name and password and imported the database.

I expected it to just work but instead, I got this error:
“Sugar CRM 6.5.16 Files May Only Be Used With A Sugar CRM 6.5.16 Database”

The same files with the same database work normally on the source server. Any ideas?

Thanks in advance.

Hi George,

Have you checked your config.php to make sure all of your database connection settings are correct?



Hello Will,

Actually I created the new database and database user using the connection info from config.php .
Even though, I double checked that it is correct by connecting to my database through command line using the connection info from config.php .

I did some tests then.
1) I changed the password inside config.php and intentionally used a wrong password. This time there was a different error:

[quote]‘Could not connect to the database. Please refer to sugarcrm.log for details.’[/quote] This shows that probably the initial error message
(“Sugar CRM 6.5.16 Files May Only Be Used With A Sugar CRM 6.5.16 Database”) doesn’t have to do with wrong database credentials

2) I went to the initial SuiteCRM instance (the one that works normally on the virtual server-before migration) and inserted the ip of the new-migrated database instead of ‘localhost’ in the next line

'db_host_name' => 'localhost',

. [color=#999999]I also corrected the password line again.[/color] This time I got the same error

So, it looks like something is wrong in my migrated database but I cannot find what. I imported the database using phpmyadmin and confirmed that the number of the tables is exactly the same.

Here are the mysql server version numbers:
Source Server mysql version: 5.5.35-0ubuntu0.12.04.1 (Ubuntu)
Destination Server mysql version: 5.5.34-0ubuntu0.12.04.1 (Ubuntu)

Any ideas?

Thanks a lot for all your help.

I’ m really sorry,

It was finally my mistake. I imported a wrong database. Seems like I should really get some more rest.

Thanks a lot for your time (and sorry for wasting some) :oops: