SuiteCRM Fresh Install - Error Displaying Sub-panel of Many-to-Many Relationships where data set is more than 1 page

New to SuiteCRM – we have just installed it and are exploring the features / capabilities. We have noticed an odd error when looking at the sub-panel of a many-to-many relationship e.g.
Account <-> Contacts – where the related detail records are displayed correctly in the subpanel until the user tries to view a subsequent page of date. E.g.

When looking at the Account Module, the associated Contacts are displayed correctly in the Sub-Panel, until user tries to view the next (or any other) page of data – in which case we get an error as follows:

Cannot GET /index.php?module=Accounts&offset=1&stamp=1458643881005198300&return_module=Accounts&action=DetailView&record=6f4bbd5d-3016-2058-8f9d-56ec136453c2&ajax_load=1&loadLanguageJS=1&Accounts_contacts_CELL_offset=10&Accounts_contacts_CELL_ORDER_BY=&sort_order=asc&to_pdf=true&action=SubPanelViewer&subpanel=contacts&layout_def_key=Accounts&inline=1&ajaxSubpanel=true

The same error occurs when viewing a Custom Module “Community” that has a Many-to-Many relationship with Contacts – again first page of related Contacts in a community displays correctly, but generates similar error when selecting anything other than the first page of data.

I’ve tried a quick repair but this has not helped.
I’ve attached two images - showing the first page of data displaying successfully and second page with error message

Any suggestions of where to start checking would be great!


After a bit of investigation we found we had a more fundamental issue

The issue is with the URL used with sub-panel javascript - our Suite.crm is installed at - when the javascript is executing the reference to suitecrm is being lost and the call to index.php is still being pre-fixed by a / e.g.


We are not sure why this is occurring because all the other URL calls are working, but nothing is working in a sub-panel e.g. sorting, pagination etc,

Can be fixed with this bit of a hack:
Open this file.
At Line 89.

Add this line before the http_fetch_sync command
url = url.slice(1);
to remove the “/” from index.php