SuiteCRM - French Language pack install

Helo i have a probleme when i tried to install the french pack on suiteCRM.

I explain the situation :
I go to the loader module
I upload the file was
I pressed install
And nothing else appear

When i install an other language i do the same and when i pressed install an other menu appear and i click on and it work.

I think the french pack is broken or something else.

Its not the first time that French language pack has issues to install due to apostrophe not being escaped in some strings.
Its an on and off problem, solved some times and broken because of translator edits.
We don’t have a list of strings that can’t have apostrophe in the values (probably they are only a few but there could be some new ones) and sometimes people change it unaware of the problems it causes.

Note: escaped apostrophe should not be a requirement for language values, but a poor code is to blame!

To solve: It would require some test to find the file that is breaking things and then to solve it by escaping the translation

Note2: you can also try this old packs:


I have downloaded and installed the latest version of SuiteCRM.
After the configuration, i wanted to add a language pack.
I installed the following:

After installation, the website is unaccessible . The browser is showing this message : currently unable to handle this request.

Thanks in advance for your quick help

Hi, you used the module loader to add your language package ?